Undefined method `to_query'

I’m trying to use a gem to access an API but I’m getting the message
=> undefined method `to_query’

I go into the terminal and run…

p RAILS_GEM_VERSION
“1.2.3”
=> nil

Object.new.methods.include?(‘to_query’)
=> false

exit

How do I add this method to my Rails installation?

Object.new.methods.include?(‘to_query’)
=> false

exit

You won’t see it from IRB, because Rails extends Object with the
methods. Try it from within 'script/console" – it works for me in
Rails 2.0.2 (not sure about 1.2.3–that’s fairly outdated).

– Mark.

Yes. Upgrading fixed it. Thanks!

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs