Undefined method `time_zone=' on Rails 2.0.2.9129 on Mac OS X

I just did a gem update and it broke my rails application. I had to
go back to 2.0.2, because 2.0.2.9129 produces this error on Mac OS X
Leopard:

/Users/nicholas/RubyDev/dummy/config/environment.rb:38: undefined
method time_zone=' for #<Rails::Configuration:0x12c9f24> (NoMethodError) from /Library/Ruby/Gems/1.8/gems/rails-2.0.2/lib/initializer.rb:47:inrun’
from /Users/nicholas/RubyDev/dummy/config/environment.rb:13
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/
ruby/1.8/rubygems/custom_require.rb:27:in gem_original_require' from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ ruby/1.8/rubygems/custom_require.rb:27:inrequire’
from /Library/Ruby/Gems/1.8/gems/activesupport-2.0.2/lib/
active_support/dependencies.rb:496:in require' from /Library/Ruby/Gems/1.8/gems/activesupport-2.0.2/lib/ active_support/dependencies.rb:342:innew_constants_in’
from /Library/Ruby/Gems/1.8/gems/activesupport-2.0.2/lib/
active_support/dependencies.rb:496:in require' from /Library/Ruby/Gems/1.8/gems/mongrel-1.1.4/bin/../lib/mongrel/ rails.rb:147:inrails’
… 20 levels…
from /Library/Ruby/Gems/1.8/gems/rails-2.0.2/lib/commands/server.rb:
39
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/
ruby/1.8/rubygems/custom_require.rb:27:in gem_original_require' from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ ruby/1.8/rubygems/custom_require.rb:27:inrequire’
from script/server:3

Guys… gem sources -r http://gems.rubyonrails.org/. Some wonky
tutorial or something prolly [accidentally] permanently added that
repo to yr gem sources. As it contains “developer” gems [which are
essentially Edge Rails snapshots], you prolly don’t want that. Just
remove that source as I suggested and remove those gem rails ending in
the revision numbers and you will be fine. Rails is not broken. All is
well in the kingdom.

RSL

Just want to say I have the same problem as well… something gone
wrong? I am using built in ruby and rails and then executed sudo gem
update

And I don’t think I have ever changed the gem sources before- so is
that mean I should never update gem using gems.rubyonrails.org?

Is that mean gem update is not safe for rails? I thought edge rails
would not come into usual update unless its planned for a public
release?

Ok thanks first, despite the message I got in IRC is a bit rude, you
do indeed point out the issue correctly and now the problem is fixed.
So- can explain a bit if I should remove the gem source from
rubyonrails.org, or thats just a intermittent issue so I just keep my
gems not update for a while and it should be ok?

You should not be updating your gems from gems.rubyonrails.org if you
are
not looking for developer gems as far as I know.

RSL

Hmm… how come its default in leopard :confused: Sorry I was from windows so
I dont have such problem (seems manually installed ruby does not have
such issue)

Thanks mate. I will remove it now.

gem sources -r http://gems.rubyonrails.org/

renders
source http://gems.rubyonrails.org/ not present in cache

I’ve uninstalled the dev gems so the only gem is now rails (2.0.2) and
all dependencies are at 2.0.2
and I still get this error

On 11 Apr 2008, at 00:05, Jake Mallory wrote:

gem sources -r http://gems.rubyonrails.org/

renders
source http://gems.rubyonrails.org/ not present in cache

I’ve uninstalled the dev gems so the only gem is now rails (2.0.2) and
all dependencies are at 2.0.2
and I still get this error

If you generated the app using the ‘bad’ rails it will still have the
offending line in its environment.rb.

Fred

it’s never been default on my computer. never had this problem and i run
leopard.

RSL

Ronny Hanssen wrote:

Note that I have removed the trailing slash (). It seems that gem is
pretty strict about the URI… :slight_smile:

Ops. Should be trailing / :stuck_out_tongue:

Jake Mallory wrote:

gem sources -r http://gems.rubyonrails.org/

renders
source http://gems.rubyonrails.org/ not present in cache

I’ve uninstalled the dev gems so the only gem is now rails (2.0.2) and
all dependencies are at 2.0.2
and I still get this error

Try:

gem sources -r http://gems.rubyonrails.org

Note that I have removed the trailing slash (). It seems that gem is
pretty strict about the URI… :slight_smile:

Ronny

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs