Undefined method `scaffold' for AdminController:Class

Hello everyone! I think a little background is necessary.

I’ve been a web-developer and linux user for a little over 4 years now,
primarily working with PHP and MySQL. I’ve tried several other
frameworks like Django and CodeIgniter and several other languages,
including python, perl, ASP/.NET, javascript and javascript frameworks,
also worked with Oracle and PostgreSQL and many many technologies like
e-commerce apps and content management systems. I’ve heard of Ruby on
Rails from the beginning but am only now realizing that this is the way
to go.

So right now I’m running Ubuntu 9.10 with Apache and Ruby 1.8.7. I tried
following this tutorial http://www.dolicapax.org/?p=11 completely but
ran into problems after using gem to install rails, as I was not able to
run the rails command in my terminal. So I ended up installing it with
aptitude. Maybe this is part of the source of my problem, as I hear that
is not the best way to do it.

Either way, I’ve been following the lynda.com ruby on rails essential
training screencasts and just about everything is working just fine
except this scaffold issue. The instructions in the screencasts are
using Ruby 1.8.4, so I’m not sure if this scaffolding convention has
changed at all since then, because I’m an absolute beginner.

Can anyone please help with this issue?

Thanks

write Down here what error are coming on console or in log files thanks

On Wed, Feb 24, 2010 at 3:35 AM, Kevin K. [email protected]
wrote:

using Ruby 1.8.4, so I’m not sure if this scaffolding convention has
“Ruby on Rails: Talk” group.
To post to this group, send email to [email protected]
To unsubscribe from this group, send email to
[email protected][email protected]
.
For more options, visit this group at
http://groups.google.com/group/rubyonrails-talk?hl=en.


Thanks:
Rajeev sharma

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs