Undefined method `run_all' for []:Array


#1

I’m using the latest ruby 1.9.3-head and recently whenever I run rspec
(2.2+) I get the following error:

I have seen others have run into this issue, but to resolve it just
rolled back to a previous version of rspec or it there a better way?

ruby-1.9.3-head/gems/rspec-core-2.3.1/lib/rspec/core/hooks.rb:116:in
run_hook_filtered': undefined methodrun_all’ for []:Array
(NoMethodError)
from /Users/kristianconsult/.rvm/gems/ruby-1.9.3-head/gems/rspec-
core-2.3.1/lib/rspec/core/example_group.rb:215:in eval_after_alls' from /Users/kristianconsult/.rvm/gems/ruby-1.9.3-head/gems/rspec- core-2.3.1/lib/rspec/core/example_group.rb:237:inrun’
from /Users/kristianconsult/.rvm/gems/ruby-1.9.3-head/gems/rspec-
core-2.3.1/lib/rspec/core/command_line.rb:27:in block (2 levels) in run' from /Users/kristianconsult/.rvm/gems/ruby-1.9.3-head/gems/rspec- core-2.3.1/lib/rspec/core/command_line.rb:27:inmap’
from /Users/kristianconsult/.rvm/gems/ruby-1.9.3-head/gems/rspec-
core-2.3.1/lib/rspec/core/command_line.rb:27:in block in run' from /Users/kristianconsult/.rvm/gems/ruby-1.9.3-head/gems/rspec- core-2.3.1/lib/rspec/core/reporter.rb:12:inreport’
from /Users/kristianconsult/.rvm/gems/ruby-1.9.3-head/gems/rspec-
core-2.3.1/lib/rspec/core/command_line.rb:24:in run' from /Users/kristianconsult/.rvm/gems/ruby-1.9.3-head/gems/rspec- core-2.3.1/lib/rspec/core/runner.rb:55:inrun_in_process’
from /Users/kristianconsult/.rvm/gems/ruby-1.9.3-head/gems/rspec-
core-2.3.1/lib/rspec/core/runner.rb:46:in run' from /Users/kristianconsult/.rvm/gems/ruby-1.9.3-head/gems/rspec- core-2.3.1/lib/rspec/core/runner.rb:10:inblock in autorun’


#2

On Sun, Jan 2, 2011 at 5:42 AM, Kristian M. removed_email_address@domain.invalid
wrote:

I’m using the latest ruby 1.9.3-head and recently whenever I run rspec
(2.2+) I get the following error:

I have seen others have run into this issue, but to resolve it just
rolled back to a previous version of rspec or it there a better way?

Better is to wait to upgrade to the next version of rspec that fixes the
bug:

https://github.com/rspec/rspec-core/issues/closed#issue/258

To be released as part of rspec-core-2.4 within the next day or so.

Cheers,
David


#3

David C. wrote in post #971870:

On Sun, Jan 2, 2011 at 5:42 AM, Kristian M. removed_email_address@domain.invalid
wrote:

I’m using the latest ruby 1.9.3-head and recently whenever I run rspec
(2.2+) I get the following error:

I have seen others have run into this issue, but to resolve it just
rolled back to a previous version of rspec or it there a better way?

Better is to wait to upgrade to the next version of rspec that fixes the
bug:

https://github.com/rspec/rspec-core/issues/closed#issue/258

To be released as part of rspec-core-2.4 within the next day or so.

Cheers,
David

I guess this isn’t fixed? I’m having the same error, and the version of
rspec that installs is 2.0.1
Unless I’m missing something obvious?