Undefined method read_nonblock in jruby 1.9 mode

Running into the following error when using jruby 1.6.1 in 1.9 mode
trying to connect to a pop account. I am using jruby-openssl 0.7.3.

E, [2011-05-10T16:38:52.279000 #2883] ERROR – : undefined method
read_nonblock' for #<OpenSSL::SSL::SSLSocket:0x689d00c9>: /home/ubuntu/.rvm/rubies/jruby-1.6.1/lib/ruby/1.9/net/protocol.rb:135:inrbuf_fill’
/home/ubuntu/.rvm/rubies/jruby-1.6.1/lib/ruby/1.9/net/protocol.rb:116:in
readuntil' /home/ubuntu/.rvm/rubies/jruby-1.6.1/lib/ruby/1.9/net/protocol.rb:126:inreadline’
/home/ubuntu/.rvm/rubies/jruby-1.6.1/lib/ruby/1.9/net/pop.rb:975:in
recv_response' /home/ubuntu/.rvm/rubies/jruby-1.6.1/lib/ruby/1.9/net/pop.rb:872:ininitialize’
/home/ubuntu/.rvm/rubies/jruby-1.6.1/lib/ruby/1.9/net/pop.rb:991:in
critical' /home/ubuntu/.rvm/rubies/jruby-1.6.1/lib/ruby/1.9/net/pop.rb:872:ininitialize’
/home/ubuntu/.rvm/rubies/jruby-1.6.1/lib/ruby/1.9/net/pop.rb:551:in
do_start' /home/ubuntu/.rvm/rubies/jruby-1.6.1/lib/ruby/1.9/net/pop.rb:528:instart’

The same error does not seem to occur in 1.8 mode.

thx.

-karl

Apologize for responding to my own thread, but did a little googling and
it looks like this is a known issue filed back in Feb.

http://jira.codehaus.org/browse/JRUBY-5529

Not really sure what my options are as i need to create secure pop3
connections and i’d hate to have to roll back to ruby 1.8 as 1.9 seems
to have solved some different issues for me. Would love to help get the
issue solved but honestly i would have no idea where to begin.

Any ideas?

thx.

-karl

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs