Undefined method `map' for nil:NilClass for rails 2.3.2

Hai guys!
When i try to do rake gems:install and rake gems:refresh_specs in my app
below error is occurred. please give some solution for this.

config.gem: Unpacked gem authlogic-2.1.3 in vendor/gems has no
specification
file. Run ‘rake gems:refresh_specs’ to fix this.
rake aborted!
undefined method `map’ for nil:NilClass

enivorment.rb

RAILS_GEM_VERSION = ‘2.3.2’ unless defined? RAILS_GEM_VERSION

Bootstrap the Rails environment, frameworks, and default configuration

require File.join(File.dirname(FILE), ‘boot’)

Rails::Initializer.run do |config|

Settings in config/environments/* take precedence over those

specified
here.

Application configuration should go into files in

config/initializers

– all .rb files in that directory are automatically loaded.

Add additional load paths for your own custom dirs

config.load_paths += %W( #{RAILS_ROOT}/extras )

Specify gems that this application depends on and have them

installed
with rake gems:install

config.gem “bj”

config.gem “sqlite3-ruby”, :lib => “sqlite3”

config.gem “aws-s3”, :lib => “aws/s3”

#config.gem “hpricot”, :version => ‘0.6’, :source => "
http://code.whytheluckystiff.net"

config.gem "fastercsv"
config.gem 'mislav-will_paginate', :version => '~> 2.3.8', :lib =>

‘will_paginate’, :source => ‘http://gems.github.com
config.gem ‘thinking-sphinx’, :lib => ‘thinking_sphinx’, :version =>
‘~>
1.3.18’, :source => ‘http://gemcutter.org’ #
config.gem ‘thinking-sphinx-raspell’, :lib =>
‘thinking_sphinx/raspell’,
:version => ‘1.1.1’, :source => ‘http://gemcutter.org’ #
config.gem “RedCloth”, :version => ‘4.1.1’, :source => ’
http://gemcutter.org’, :lib => ‘redcloth’
config.gem ‘isbn-tools’, :lib=>“isbn/tools”, :version => “~>0.1.0”
config.gem “authlogic”
config.gem “activemerchant”, :lib => “active_merchant”, :version =>
“1.5.1”
config.gem ‘bullet’, :source => ‘http://gemcutter.org
config.gem ‘campaign_monitor_party’, :source =>
http://gemcutter.org
config.gem ‘whenever’, :lib => false, :source =>
http://gemcutter.org/

config.gem 'metric_fu', :version => '1.3.0', :lib => 'metric_fu' #
config.gem 'reek', :version => '1.2.7.3'
config.gem 'roodi', :version => '2.1.0'
config.gem 'hoptoad_notifier'
config.gem 'pingfm', :version => '1.0.2'
config.gem 'handsoap', :version => '1.1.7'
config.gem 'flay', :version => '1.4.0'
config.gem 'rcov', :version => '0.9.8'
config.gem 'churn', :version => '0.0.12'
config.gem 'gem_plugin', :version => '0.2.3'
config.gem 'chronic', :version => '0.2.3'
config.gem 'andand', :version => '1.3.1'
config.gem 'sinatra', :version => '1.0'
config.gem 'recurrence', :version => '0.1.1'
config.gem 'daemons', :version => '1.1.0'
config.gem 'ean13', :version => '1.4.0'
config.gem 'htmldoc', :version => '0.2.3'
config.gem 'flog', :version => '2.2.0'
config.gem 'after_commit', :version => '1.0.7'
config.gem 'riddle', :version => '1.0.12'

Thanks and Regards,

Dhamodharan.N

Hi,
Have you tried to reinstall authlogic-2.1.3?
Do you have it in vendor/gems?

Andrei

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs