Undefined method `get_client_info' for Mysql:Class

after upgraded to Snow Leopard… (32bits arch)

I re-installed the mysql gem (i386 architecture) , all gems and
rails 2.3.4
testing in the console

$ irb
irb(main):001:0> require ‘rubygems’
=> true
irb(main):002:0> require ‘mysql’
=> true

NoMethodError: undefined method `get_client_info’ for Mysql:Class
from (irb):3

I should get “5.1.38” (MySQL installed db version…) or did the
Mysql class changed w Rails 2.3.4 ?
is this test wrong ?

thanks for your advices

Your test works for me.

But I had a horrible time getting everything working on a Macbook.

I have no idea what finally worked, as I was trying so many different
things and then walked away whistling when it finally did work.

Did you do an upgrade, or a clean install? I did an upgrade and I
think that was the source of most of my problems. I also had no issue
at all with a 64bit iMac.

What finally worked for me:

install mysql-5.1.38-osx10.5-x86_64 (from mysql.org). Then install
the mysql gem with:
env ARCHFLAGS=“-arch x86_64” gem install mysql – --with-mysql-

Run this ruby script to see what other gems are broken in the 32->64
bit transition: 178178’s gists · GitHub

There’s some more detail in the following:

I am stupid and bad writer …

NoMethodError: undefined method `get_client_info’ for Mysql:Class
from (irb):3

it happens because I wrote the bad method, should have written :

=> “5.1.38”