Undefined constant Engines with Rails 1.0 + svn trunk


#1

There seems to be an issue when running Rails 1.0 and the latest trunk
version of Engines itself. If I gather correctly this version should be
compatible with both 1.0 as well as EDGE/1.1. It happens in the file:
dependencies_extensions.rb.


#2

As it happens, now I’m getting Stack Level too Deep errors using Edge
Rails + svn trunk of Engines plugin.

Ouch…


#3

Have you followed the instructions in the README file / on the website
regarding Edge Rails and Engines?

http://rails-engines.org/wiki/pages/Using+Engines+with+Edge+Rails

Basically, it sounds like the engines plugin is trying to use the
‘old’ dependency loading mechanism.

  • james

On 3/19/06, Fabien removed_email_address@domain.invalid wrote:

http://lists.rails-engines.org/listinfo.cgi/engine-users-rails-engines.org

  • J *
    ~