Unable to send mail

Hi all i am trying to send mail but i could not send it and at the end
it
is redirecting to right page but mail is not receiving.

i got this in my log

Sent mail to mailid

Date: Tue, 18 Sep 2012 19:38:51 +0530
From: xxxx
To: xxxx
Subject: fdfdsafsdafdsfsfsdafdsf
Mime-Version: 1.0
Content-Type: text/plain; charset=utf-8

dfsadfdsfsdafsfsdfsdfsd
Redirected to http://localhost:3000/student/profile/776
Completed in 5696ms (DB: 3) | 302 Found
[http://localhost/student/email/776]

UserMailer::deliver_email(sender, recipient_list,
params[‘email’][‘subject’], params[‘email’][‘message’])

class UserMailer < ActionMailer::Base
def email(sender,recipients, subject, message)

recipient_emails = (recipients.class == String) ? recipients.gsub('

‘,’’).split(’,’).compact : recipients.compact
setup_email(sender, recipient_emails, subject, message)
end

protected
def setup_email(sender, emails, subject, message)
logger.info"i am in SETUP"
@from = sender
@recipients = emails
@subject = subject
@sent_on = Time.now
@body[‘message’] = message
end

end

Config/intializers/smtp_gmail

ActionMailer::Base.smtp_settings = {
:address => “smtp.gmail.com”,
:port => 587,
:authentication => :plain,
:enable_starttls_auto => true,
:user_name => “xxxx”,
:password => “xxxxx”
}

till def setup_email i am able to reach it but i am not receiving mail.

Cheers,
KP

Can you check your spam folder in your mailbox ?

yeah i am getting my mails not to my inbox . what should i do to get my
mail to inbox

On Tue, Sep 18, 2012 at 8:30 PM, Avi [email protected] wrote:

What is your html content ?

Welcome

Try not to use "&, # " in your html.

i did not get this line

What is your html content ?
Try not to use "&, # " in your html.
Hope it works.

If there is an extra space, some symbols(which are spam) or any spam
words,
the mail goes to the spam folder.
Try with a sentence(all words).

I have sent a big text but still the same i am getting mail in spam

On Sep 18, 2012, at 11:24 AM, keerthi priya wrote:

I have sent a big text but still the same i am getting mail in spam

You can’t really do anything about spam filters from the sending side,
except to make your mail look less “spammy”. Companies like MailChimp
and SendGrid spend millions to figure this out and to stay off of
blacklists, and it makes sense for them to invest like that, since they
are sending at scale. If getting your message into the in-box instead of
the spam-box is your goal, you might want to use SendGrid (since there’s
a gem) and make sure that your message comes from a trusted
address/server.

My own personal solution to this is to use my client’s Exchange server
as the sender, since their clients are likely to have white-listed the
host in the past. Another pro tip is to use plain text mail only, avoid
HTML or attachments. There’s more of an art than a science to this, and
it’s a moving battle with the spam filters, I’m afraid.

Walter

& may be you can try giving a meaningful subject to the email.

i tried that also but still the same.

Not sure, because I was facing the same problem, & I removed spaces &
unnecessary symbols, & it worked fine for me.

Try adding :- :domain => “gmail.com” in your mailer setting. &
you may modify your method
In user.rb :-
def email
UserMailer.email(self).deliver
end

In usermailer.rb :-

def email(user)
@user = user
mail(:to => user.email, :subject => “Welcome!!”)
end

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs