Unable to run .rb file with SCITE editor

I have re-installed Ruby on my pc and run some rb files but these files
are not giving any output rather gives error ‘The system cannot find the
file specified.’ The same files were working before re-installation but
are not working later. Please help…

Sanjeev O. wrote:

I have re-installed Ruby on my pc and run some rb files but these files
are not giving any output rather gives error ‘The system cannot find the
file specified.’ The same files were working before re-installation but
are not working later. Please help…

try reinstalling, and/or right click on them -> “open wish”, choose
SciTe, check the “always open with” checkbox.
GL.
-r

Thanks Roger for your comments,

I believe you are under impression that I am not able to open file with
SCITE editor but the actual problem is if I am saving the .rb file and
trying to run the code by ‘F5’ button then it gives me error ‘the system
cannot find the file specified.’

On Feb 17, 9:03 am, Sanjeev O. [email protected] wrote:

Thanks Roger for your comments,

I believe you are under impression that I am not able to open file with
SCITE editor but the actual problem is if I am saving the .rb file and
trying to run the code by ‘F5’ button then it gives me error ‘the system
cannot find the file specified.’


Posted viahttp://www.ruby-forum.com/.

SOunds like the new install didn’t add your ruby bin dir to the path

I think you can also edit the ruby properties file (in SciTe) to give
the full path to ruby.exe

I updated Ruby properties file in “C:\ruby\scite” as per your above
instruction but the error message not changed yet.

Sanjeev O. wrote:

I updated Ruby properties file in “C:\ruby\scite” as per your above
instruction but the error message not changed yet.

You’ve to restart SciTE afterwards.
What about pathnames without spaces? Try placing a script directly as
C:\myscript.rb and then run it from inside SciTE. Does this work?

SOunds like the new install didn’t add your ruby bin dir to the path
Yeah, that’s also possible. Type “ruby -v” in cmd and post the output.

Marvin

Sanjeev O. wrote:

Thanks Roger for your comments,

I believe you are under impression that I am not able to open file with
SCITE editor but the actual problem is if I am saving the .rb file and
trying to run the code by ‘F5’ button then it gives me error ‘the system
cannot find the file specified.’

I suppose your script directory path or the script name itself contains
whitespace. SciTE can cope with that, just open the Ruby options file
(you’ll have to be root on Linux systems) via SciTEs Options -> Edit
Properties -> Open Ruby properties menu and change the entry
command.go..rb=ruby $(FileNameExt)
to
command.go.
.rb=ruby “$(FileNameExt)”
. Note the quotes.
There are two entries, one for the GTK platform and one for Windows,
choose that one apropriate for you.

Marvin

Sanjeev O. wrote:

Marvin,

I have restarted SciTE afterwards but it doesn’t work.
I have tried to run the ruby file from root directory by using SciTE but
it gives me same output and if i am typing “ruby -v” in cmd then it
gives me error says 'ruby’is not recognised as an internal or external
command…

ruby.exe is most likely not in your path then. Reinstall ruby and
reboot :slight_smile:
-r

Thanks Roger,

For your kind help as the issue is resolved after successfull
re-installment of Ruby.

Marvin,

I have restarted SciTE afterwards but it doesn’t work.
I have tried to run the ruby file from root directory by using SciTE but
it gives me same output and if i am typing “ruby -v” in cmd then it
gives me error says 'ruby’is not recognised as an internal or external
command…

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs