Unable to "require" installed gems

Hi,

I’ve installed sqlite3 (via the instructions at
http://wiki.rubyonrails.org/rails/pages/HowtoUseSQLite), and all went
well

OSX 10.4.7

ruby 1.8.4 (2005-12-24) [powerpc-darwin8.6.0]

and sqlite3.rb is in
/usr/local/lib/ruby/gems/1.8/gems/sqlite3-ruby-1.1.0/lib

but I can’t <require ‘sqlite3’>

caw$ irb
irb(main):001:0> require ‘sqlite3’
LoadError: no such file to load – sqlite3
from (irb):1:in `require’
from (irb):1
irb(main):002:0>

and when I look at the load path
irb(main):002:0> $:
=> ["/usr/local/lib/ruby/site_ruby/1.8",
“/usr/local/lib/ruby/site_ruby/1.8/powerpc-darwin8.6.0”,
“/usr/local/lib/ruby/site_ruby”, “/usr/local/lib/ruby/1.8”,
“/usr/local/lib/ruby/1.8/powerpc-darwin8.6.0”, “.”]

the path to the gems directory doesn’t seem to be there.

What’s the missing piece of the puzzle?

Thanks for your help

Chris

On Wednesday, August 02, 2006, at 10:21 PM, Chris Wright wrote:

and sqlite3.rb is in
/usr/local/lib/ruby/gems/1.8/gems/sqlite3-ruby-1.1.0/lib

but I can’t <require ‘sqlite3’>

caw$ irb
irb(main):001:0> require ‘sqlite3’

First, you must require rubygems, then require sqlite3.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs