Unable to locate component

I installed ruby on rails on windows xp and created and project (rails
my_project). I started the server(ruby script\server). I openned the
browser and launch the page (http://localhost:3000/). When I selected a
link on the page, a message pop-up on my screen: “This application has
failed to start because sqlite3.dll was not found. Re-installing the
application may fix this problem”.

I did install sqlite3.

What a I doing wrong?

Thanks for your help

On Tue, Jul 20, 2010 at 10:29 AM, Hugo N. [email protected] wrote:

What a I doing wrong?

Is sqlite3.dll in you path? The recommended[1] way to do it is to
copy that file to C:\ruby\bin.

Hope that helps.

Gordon

[1]
http://blog.mmediasys.com/2009/07/06/getting-started-with-rails-and-sqlite3/

Hugo N. wrote:

I installed ruby on rails on windows xp and created and project (rails
my_project). I started the server(ruby script\server). I openned the
browser and launch the page (http://localhost:3000/). When I selected a
link on the page, a message pop-up on my screen: “This application has
failed to start because sqlite3.dll was not found. Re-installing the
application may fix this problem”.

I did install sqlite3.

What a I doing wrong?

Thanks for your help

Thanks for your help!!! I fix the issue. I had to extract the files in
the c:\ruby\bin folder as you mentionned.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs