Unable to install pg gem file on CENT OS

please help me in this… I am unable to install pg gem file

[[email protected] ~]# gem install pg -v ‘0.12.0’
/usr/local/lib/ruby/1.9.1/yaml.rb:56:in `<top (required)>’:
It seems your ruby installation is missing psych (for YAML output).
To eliminate this warning, please install libyaml and reinstall your
ruby.
Fetching: rake-compiler-0.8.1.gem (100%)
Fetching: pg-0.12.0.gem (100%)
Building native extensions. This could take a while…
ERROR: Error installing pg:
ERROR: Failed to build gem native extension.

    /usr/local/bin/ruby extconf.rb

checking for pg_config… no
No pg_config… trying anyway. If building fails, please try again with
–with-pg-config=/path/to/pg_config
checking for libpq-fe.h… no
Can’t find the 'libpq-fe.h header
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

Provided configuration options:
–with-opt-dir
–without-opt-dir
–with-opt-include
–without-opt-include=${opt-dir}/include
–with-opt-lib
–without-opt-lib=${opt-dir}/lib
–with-make-prog
–without-make-prog
–srcdir=.
–curdir
–ruby=/usr/local/bin/ruby
–with-pg
–without-pg
–with-pg-dir
–without-pg-dir
–with-pg-include
–without-pg-include=${pg-dir}/include
–with-pg-lib
–without-pg-lib=${pg-dir}/lib
–with-pg-config
–without-pg-config
–with-pg_config
–without-pg_config

Gem files will remain installed in
/usr/local/lib/ruby/gems/1.9.1/gems/pg-0.12.0 for inspection.
Results logged to
/usr/local/lib/ruby/gems/1.9.1/gems/pg-0.12.0/ext/gem_make.out

Install postgresql-libs and also recompile your Ruby after install
libyaml.

On Tue, Dec 4, 2012 at 6:50 AM, PavanKumar Chamarthi

You will need to install libyaml-devel from the epel repositories (which
you will also need to add).

PavanKumar Chamarthi wrote in post #1087845:

please help me in this… I am unable to install pg gem file

[[email protected] ~]# gem install pg -v ‘0.12.0’
/usr/local/lib/ruby/1.9.1/yaml.rb:56:in `<top (required)>’:
It seems your ruby installation is missing psych (for YAML output).
To eliminate this warning, please install libyaml and reinstall your
ruby.
Fetching: rake-compiler-0.8.1.gem (100%)
Fetching: pg-0.12.0.gem (100%)
Building native extensions. This could take a while…
ERROR: Error installing pg:
ERROR: Failed to build gem native extension.

    /usr/local/bin/ruby extconf.rb

checking for pg_config… no
No pg_config… trying anyway. If building fails, please try again with
–with-pg-config=/path/to/pg_config

checking for libpq-fe.h… no
Can’t find the 'libpq-fe.h header
*** extconf.rb failed ***

It is in your own interest to provide more detail respecting your
installation when reporting a problem and asking for help. For example,
are you running CentOS-6 or 5? What point release? Are you using the
stock PostgreSQl install, have you installed a different version from
another respoitory, or have you built PostgreSQl yourself? In any case
what version of Postgres?

Providing that you are running CentOS-6.x; and assuming that you are
evidently not using the Postgres provided with that distribution; and
guessing that you are likely using the pgdg-91-centos.repo; and also
guessing that you are using either rvm or rbenv then you likely need to
do something akin to the following

yum install postgresql91-devel libyaml
gem install pg --with-pg-config=/usr/pgsql-9.1/bin/pg_config

HTH

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs