Unable to Connect

Hey folks,

I’m just starting out learning Rails, so I picked up “Agile Web
Development with Rails” and tried to get a demo server going. I
entered the command C:\Sites\demo>rails server and got the
following messages:

=> Booting WEBrick
=> Rails 3.0.7 application starting in development on
http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
[2011-05-06 17:57:30] INFO WEBrick 1.3.1
[2011-05-06 17:57:30] INFO ruby 1.8.7 (2011-02-18) [i386-mingw32]
[2011-05-06 17:57:30] INFO WEBrick::HTTPServer#start: pid=5756
port=3000

However, when I try to go to http://0.0.0.0:3000 in a browser, I get a
“unable to load” error. What a let down. I shut off my firewall and
disable the Hosts manager, but I really have no idea what I’m doing.
I tried in Firefox and IE, am running XP SP3. Any advice, or
additional information I could give that would be helpful?

Thanks a ton,

Jay

On May 6, 11:14pm, Jay [email protected] wrote:

=> Ctrl-C to shutdown server

0.0.0.0 isn’t a valid address - it’s short hand for “I’m listening on
all ip addresses this machine has”. You should be able to connection
to 127.0.0.1:3000

Fred

The output:
=> Rails 3.0.7 application starting in development on
http://0.0.0.0:3000

means that your application server is listening on any address your
computer might have. To connect to a network service on your own machine
you usually use the 127.0.0.1 as Fred already mentioned. But this
IP-Address only works on you local machine.

Jens

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs