Uhd source install gentoo

i am trying to do a install of the UHD lib/drivers on gentoo. the cmake
program returns the following.

[email protected] ~/uhd/host/build $ cmake …/

– Configuring the python interpreter…
– Python interpreter: /usr/bin/python2.6
– Override with: -DPYTHON_EXECUTABLE=
– Build type not specified: defaulting to release.

– Configuring Boost C++ Libraries…
– Boost include directories: /usr/include
– Boost library directories: /usr/lib
– Boost libraries:
/usr/lib/libboost_date_time-mt.so;/usr/lib/libboost_filesystem-mt.so;/usr/lib/libboost_program_options-mt.so;/usr/lib/libboost_regex-mt.so;/usr/lib/libboost_system-mt.so;/usr/lib/libboost_thread-mt.so;/usr/lib/libboost_unit_test_framework-mt.so

– Python checking for Python version 2.6 or greater
– Python checking for Python version 2.6 or greater - unknown error

– Python checking for Cheetah templates 2.0.0 or greater
– Python checking for Cheetah templates 2.0.0 or greater - unknown
error

– Configuring LibUHD support…
– Dependency Boost_FOUND = TRUE
– Dependency HAVE_PYTHON_PLAT_MIN_VERSION = FALSE
– Dependency HAVE_PYTHON_MODULE_CHEETAH = FALSE
– Disabling LibUHD support.
– Override with -DENABLE_LIBUHD=ON/OFF

– Configuring Examples support…
– Dependency ENABLE_LIBUHD = OFF
– Disabling Examples support.
– Override with -DENABLE_EXAMPLES=ON/OFF

– Configuring Utils support…
– Dependency ENABLE_LIBUHD = OFF
– Disabling Utils support.
– Override with -DENABLE_UTILS=ON/OFF

– Configuring Tests support…
– Dependency ENABLE_LIBUHD = OFF
– Disabling Tests support.
– Override with -DENABLE_TESTS=ON/OFF

– Could NOT find Docutils (missing: RST2HTML_EXECUTABLE)

– Configuring Manual support…
– Dependency DOCUTILS_FOUND = FALSE
– Disabling Manual support.
– Override with -DENABLE_MANUAL=ON/OFF


– Configuring Doxygen support…
– Dependency DOXYGEN_FOUND = YES
– Enabling Doxygen support.
– Override with -DENABLE_DOXYGEN=ON/OFF

– Configuring USRP-E Utils support…
– Dependency LINUX = TRUE
– Disabling USRP-E Utils support.
– Override with -DENABLE_USRP_E_UTILS=ON/OFF

– ######################################################
– # UHD enabled components
– ######################################################
– * Doxygen

– ######################################################
– # UHD disabled components
– ######################################################
– * LibUHD
– * Examples
– * Utils
– * Tests
– * Manual
– * USRP-E Utils

– Building version: 003.004.000-6795022
– Using install prefix: /usr/local
– Configuring done
– Generating done
– Build files have been written to: /home/david/uhd/host/build

I believe the files its looking for are installed in /usr/lib64
How do i specify this to cmake? im not to familar with it.
I tried cmake-gui and i get Boost_DIR-NOTFOUND for Boost-dir

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs