Uhd_rx_nogui Bad Argument

Hello,

I have been trying to get the above mentioned working with the following
command but got the output shown:

[email protected]:/usr/local/bin$ uhd_rx_nogui -f 92400000 -m FM -O
hw:0,0 -o 44100 --show-async-msg
linux; GNU C++ version 4.6.1; Boost_104601;
UHD_003.004.003-174-gd18fc6f0

– Opening a USRP1 device…
– Using FPGA clock rate of 64.000000MHz…

gr_fir_ccf: using SSE
Using gain: 25.75

gr_fir_ccc: using SSE
gr_fir_fff: using SSE
audio_alsa_sink[hw:0,0]: set_period_time_near failed: Invalid argument
Traceback (most recent call last):
File “/usr/local/bin/uhd_rx_nogui”, line 256, in
main()
File “/usr/local/bin/uhd_rx_nogui”, line 249, in main
tb = app_top_block(options)
File “/usr/local/bin/uhd_rx_nogui”, line 192, in init
options.audio_output)
File
“/usr/local/lib/python2.7/dist-packages/gnuradio/audio/audio_swig.py”,
line 345, in sink
return _audio_swig.sink(*args, **kwargs)
RuntimeError: audio_alsa_sink

How do I fix the bad argument?

Thanks,
Jeremy

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs