UHD not working after clean pybombs install

Hello,

I did find a simlar entry to this problem on the forum from last month
but
there was no usable solution for me unless I missed something. Also I
have
not found a way to allow me to change the USB permissions. Any advise
will
be a great help.

Thanks
John

I have this issue on TWO DIFFERENT MACHINES. Here is what I did on each
of
them:

Completely fresh install of Ubuntu 12.04.4 LTS
apt-get update
apt-get upgrade
apt-get libasound2-dev (because I need to use an 8 channel USB sound
card
with my GRC app)
install and configure pybombs (used all default settings)
./pybombs install gnuradio

each time I want to run gnuradio-companion I must first set the
enviroment
(a minor annoyance)

./pybombs env
source /home/xxxx/target/setup_env.sh
sudo /home/xxxx/target/lib/uhd/utils/uhd_images_downloader.py

and then

gnuradio_companion (GRC 3.7.5 GUI works fine)

However, I have no connection to the USRP B200

uhd_find_devices or uhd_usrp_probe returns the following:

UHD Error:
USB open failed: insufficient permisssions.
See the application notes for your device.
No UHD Devices Found

running lsusb returns the following:

Bus 002 Device 006: ID 2500:0200

according the information in ~/target/lib/uhd/utils/uhd_usrp.rules, ID
2500:0200 is the B200 USRP

On Fri, Jul 11, 2014 at 9:27 AM, John M. [email protected]
wrote:

I have this issue on TWO DIFFERENT MACHINES. Here is what I did on each
each time I want to run gnuradio-companion I must first set the enviroment
(a minor annoyance)

./pybombs env

You only need to run this once to create the environment setup file.

source /home/xxxx/target/setup_env.sh

You can put this in your ~/.bashrc (or equivalent) file to set up your
environment when you log in.

sudo /home/xxxx/target/lib/uhd/utils/uhd_images_downloader.py

Again, this only needs to be done once, unless the UHD images change.

     USB open failed: insufficient permisssions.
     See the application notes for your device.

No UHD Devices Found

running lsusb returns the following:

Bus 002 Device 006: ID 2500:0200

according the information in ~/target/lib/uhd/utils/uhd_usrp.rules, ID
2500:0200 is the B200 USRP

Copy the uhd_usrp.rules file into /etc/udev/rules.d/ and then reload the
udev rules:

$ sudo udevadm control --reload-rules

Tom

You may need the rtprio also. See notes at below link I have been
keeping:

http://rfpoweramp.wordpress.com/2014/06/10/setting-up-the-usrp-b200/

Note there is something screwed up with Worpress and quotes pasted from
the
Linux shell, so be careful if pasting in that text.

Lou
KD4HSO

John M. wrote

Hello,

I did find a simlar entry to this problem on the forum from last month but
there was no usable solution for me unless I missed something. Also I
have
not found a way to allow me to change the USB permissions. Any advise will
be a great help.

Thanks
John


View this message in context:
http://gnuradio.4.n7.nabble.com/UHD-not-working-after-clean-pybombs-install-tp49280p49282.html
Sent from the GnuRadio mailing list archive at Nabble.com.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs