Uhd_fft not resonding

I’m using Ubuntu 14.04, UHD_003.008.00-18-g864f84b5 and GNU Radio 3.7.6

Whenever I start uhd_fft from a command line, the window opens and
starts
to plot. After about a second, the window goes into not responding mode,
where it greys out and you can’t click anything. Does anyone know what
could be causing this behaviour? Is it a local setting of mine?

Rich

On 12/18/2014 07:39 PM, Richard B. wrote:

I’m using Ubuntu 14.04, UHD_003.008.00-18-g864f84b5 and GNU Radio 3.7.6

Whenever I start uhd_fft from a command line, the window opens and
starts to plot. After about a second, the window goes into not
responding mode, where it greys out and you can’t click anything. Does
anyone know what could be causing this behaviour? Is it a local setting
of mine?

Are you using Ubuntu’s unity?

It might be a GL issue. Try if setting style = nongl will help.

M

See “to enable OpenGL sinks” here:

You’ll use “style=nongl”, instead of “style=auto” or “style=gl”

On 2014-12-18 14:25, Richard B. wrote:

starts to plot. After about a second, the window goes into not


Discuss-gnuradio mailing list
[email protected]
Discuss-gnuradio Info Page [1]


Discuss-gnuradio mailing list
[email protected]
Discuss-gnuradio Info Page [1]

Links:

I don’t know if this matters, but I used the pybombs install method. I
am
looking for the .conf file, but the only thing in my .gnuradio directory
is

~/.gnuradio/prefs/vmcrcbuf_default_factory

Yes I’m using Unity. I forgot to mention my hardware, which is an N210
with
WBX daughterboard.

I’m not sure how to make the style change like you mentioned.

On Thu, Dec 18, 2014 at 10:54 AM, Martin B. [email protected]

I created ~/.gnuradio/config.conf with the following lines in it

[wxgui]
style=nongl

This has not fixed the window not responding issue. Any other ideas?

Rich

On Thu, Dec 18, 2014 at 11:33 AM, Richard B. [email protected]

When the window greys out, my CPU is only at 45% usage.

When I run uhd_usrp_probe I get all the device info you would expect to
get. The command works as it should.

Rich

The key setting that mleech pointed out was setting the fft-rate lower,
uhd-fft --fft-rate 5.

I suppose the N210 can’t handle the default setting, since my laptop
(corei7, 16 gig ram) doesn’t seem to be the bottleneck going by cpu
usage
and mem usage.

On Thu, Dec 18, 2014 at 11:57 AM, Richard B. [email protected]

When a window greys out, it typically means you’re using too much CPU.

Ron

The N210 neither knows, nor cares, what is going on on your CPU, nor
whether there’s enough CPU for it to send samples to you. To use a
physical-world analogy, Niagara Falls neither knows, nor cares, whether
the bucket you’re holding at the bottom of it to “capture” it is big
enough–it’ll just keep on being Niagara Falls regardless.

Also, you’d quoted 45% CPU consumption, which is total consumption,
which means that at least ONE CPU was probably totally-pegged.

Individual processes don’t automatically occupy multiple CPUs. That’s
not how multi-core systems work. The kernel schedules threads across
multiple CPUs the best it can. A single process thread can still
“starve” for CPU, even if other threads, on other CPUs are “happy”. In
this case the thread that was doing your FFT display logic was probably
running into CPU limitations–the wxGUI FFT sink (which is what is used
by uhd_fft) isn’t the most efficient. However, on a modern i7 CPU, it
should still be able to support 15 updates/second, so I’m guessing that
your CPU performance profile is set to something like “power saving” or
similar. You’ll have to research how to adjust that on Ubuntu under
Unity, since I don’t know myself.

On 2014-12-18 15:24, Richard B. wrote:

Rich
[wxgui]

Yes I’m using Unity. I forgot to mention my hardware, which is an N210 with WBX
daughterboard.

responding mode, where it greys out and you can’t click anything. Does
Discuss-gnuradio mailing list
[email protected]
Discuss-gnuradio Info Page [1]


Discuss-gnuradio mailing list
[email protected]
Discuss-gnuradio Info Page [1]


Discuss-gnuradio mailing list
[email protected]
Discuss-gnuradio Info Page [1]


Discuss-gnuradio mailing list
[email protected]
Discuss-gnuradio Info Page [1]


Discuss-gnuradio mailing list
[email protected]
Discuss-gnuradio Info Page [1]

Links: