UHD Driver Not Working

An attempt to use PyBOMBS to install GNU Radio resulted in no errors.
However, the UHD driver must have installed incorrectly, because the
source and sink blocks are not working. Is there any way to fix this
problem?

-Carl

On Tue, Jun 17, 2014 at 2:25 AM, Carl C. [email protected] wrote:

An attempt to use PyBOMBS to install GNU Radio resulted in no errors.
However, the UHD driver must have installed incorrectly, because the source
and sink blocks are not working. Is there any way to fix this problem?

-Carl

I guess you are not installing on Ubuntu Linux.
I experienced the same problem [1] when using PyBOMBS to install
gnuradio
on Debian Wheezy.
Nevertheless the link below may worth referred.

In short, you may try these in sequence:
a). Run “./pybombs env” and then “source …/target/setup_env.sh”
b). Search for “uhd_usrp_source.xml” and make sure that this is in your
GRC path
c). Manually remove all ghost version of uhd and reinstall it using
pybombs.

http://gnuradio.4.n7.nabble.com/PyBOMBS-installed-gnuradio-uhd-usrp-sink-not-found-td48388.html

On Tue, Jun 17, 2014 at 11:41 AM, fnguyen [email protected] wrote:

I’m not really sure what’s up, but I’ve set up the environments and
verified the paths. Anyone else have any ideas?

Any advice is much appreciated.

Thanks,
Francis

yum install gnuradio

I believe they are keeping GNU Radio up to date pretty well on Fedora
these
days.

Tom

Hey Carl,
I’m having the same issue on my Fedora boxes. I have two Fedora 20
boxes. On the first one I removed everything related to UHD and GNU
Radio and then ran pybombs as uhd first and then GNU Radio. That worked
fine for that box so maybe give that a try; however, I replicated the
same steps on my 2nd Fedora box, but it’s still missing the UHD
components(source and sink blocks in GRC and unable to do
uhd_find_devices, etc.). On occasion when I remove everything and
reinstall uhd and Gnuradio, it’ll have the uhd drivers, but not GRC and
its related components.

I’m not really sure what’s up, but I’ve set up the environments and
verified the paths. Anyone else have any ideas?

Any advice is much appreciated.

Thanks,
Francis

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs