UDP driver

Hello,

I burned in my SD card the UDP FPGA image and the FIRMWARE of basic tx
and
rx for UDP

http://code.ettus.com/redmine/ettus/attachments/74
http://ettus.com/u2bin/txrx_udp_20100507.bin

After powering the USRP2, only the two leds of Image and FPGA and on,
which
is fine.

My feeling was that I can be able to ping the USRP to 192.168.10.2 being
my
host computer 192.168.10.1
I cannot see the USRP. In fact running a sniffer I see nothing from the
USRP. (Neither in Windows nor Ubuntu)

I made sure that there is no firewall blocking the UDP traffic.

What can be wrong?
Many thanks,
Jorge.

On 10/20/2010 03:57 PM, Jorge M. wrote:

The “UDP Beta” firmware does not have a complete IP stack, and doesn’t
reply to ICMP ECHO (ping) traffic.

If you are heading down the UHD road (which you should be), then you’ll
need the latest UHD Firmware/FPGA images:

http://www.ettus.com/downloads/uhd_images/


Marcus L.
Principal Investigator
Shirleys Bay Radio Astronomy Consortium
http://www.sbrac.org

Marcus D. Leech wrote in post #955907:

On 10/20/2010 03:57 PM, Jorge M. wrote:

The “UDP Beta” firmware does not have a complete IP stack, and doesn’t
reply to ICMP ECHO (ping) traffic.

If you are heading down the UHD road (which you should be), then you’ll
need the latest UHD Firmware/FPGA images:

http://www.ettus.com/downloads/uhd_images/


Marcus L.
Principal Investigator
Shirleys Bay Radio Astronomy Consortium
http://www.sbrac.org

Hi!
Ok, I doesn’t have a complete IP stack, but does it provide any type of
functionality?
For example I tried it, and I can’t even get a positive reply from
“find_usrps”.
The thing is I’m trying to use USRP2 with Matlab2010b, and so far
although Simulink provides USRP2 functional blocks, they don’t seem to
work, because there is no functional UDP support from Ettus research.
Any ideas?
Thanks,

Vlad.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs