Tzinfo on dreamhost - help?


#1

Hey everyone -

I googled till my face was blue and finally managed to update my setup
at
dreamhost to run “local” gems. Installed the tzinfo gem from a mirror
and
updated my app to Rails edge.

I fired up the console in my app to check if my subsequent install of
tzinfo
worked out and here’s the output.

$ ruby script/console
Loading development environment.

gem ‘tzinfo’
=> true

include TZInfo
NameError: uninitialized constant TZInfo
from
./script/…/config/…/config/…/vendor/rails/activerecord/lib/…/…/activesupport/lib/active_support/dependencies.rb:267:in
load_missing_constant' from ./script/../config/../config/../vendor/rails/activerecord/lib/../../activesupport/lib/active_support/dependencies.rb:453:inconst_missing’
from
./script/…/config/…/config/…/vendor/rails/activerecord/lib/…/…/activesupport/lib/active_support/dependencies.rb:465:in
`const_missing’
from (irb):2

exit

I also tried -

require ‘Tzinfo’
MissingSourceFile: no such file to load – Tzinfo
from
/home/myusername/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in
gem_original_require' from /home/myusername/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:inrequire’
from
./script/…/config/…/config/…/vendor/rails/activerecord/lib/…/…/activesupport/lib/active_support/dependencies.rb:496:in
require' from ./script/../config/../config/../vendor/rails/activerecord/lib/../../activesupport/lib/active_support/dependencies.rb:343:innew_constants_in’
from
./script/…/config/…/config/…/vendor/rails/activerecord/lib/…/…/activesupport/lib/active_support/dependencies.rb:496:in
`require’
from (irb):3

I don’t know if it helps but here’s the info for my app’s environment.

$ ruby script/about
About your application’s environment
Ruby version 1.8.5 (i386-linux)
RubyGems version 0.9.1
Rails version 1.2.0
Active Record version 1.14.4
Action Pack version 1.12.5
Action Web Service version 1.1.6
Action Mailer version 1.2.5
Active Support version 1.3.1
Edge Rails revision 6079
Application root /home/myusername/appname/appname
Environment development
Database adapter mysql

Can anyone give me a tip? I’m lost here :(. Thanks in advance!

  • Joel