Typo on Edge Rails


#1

Has anyone gotten Typo to work on Edge Rails (1.1)? I have a few 1.1
specific extensions I’d like to add.

The initial error I received was:

/public/…/config/environment.rb:107: undefined method
`enable_upload_progress’ for ActionController::Base:Class
(NoMethodError)

so I commented the line out and added the Upload Progress plugin.

After this I receive the following error which is where I’m stuck:

uninitialized constant Plugins

#{RAILS_ROOT}/vendor/rails/activerecord/lib/…/…/activesupport/lib/
active_support/dependencies.rb:106:in const_missing' #{RAILS_ROOT}/vendor/rails/activerecord/lib/../../activesupport/lib/ active_support/dependencies.rb:133:inconst_missing’
#{RAILS_ROOT}/components/plugins/textfilters/amazon_controller.rb:1
#{RAILS_ROOT}/app/controllers/textfilter_controller.rb:113
#{RAILS_ROOT}/app/controllers/textfilter_controller.rb:112:in `each’
#{RAILS_ROOT}/app/controllers/textfilter_controller.rb:112
#{RAILS_ROOT}/app/controllers/application.rb:33

Any thoughts other than “rake unfreeze rails”? :slight_smile:

Thanks.
Steven S.
FiveRuns


#2

At the moment, Typo does not work on edge rails. Now that 1.1 release
candidate just came out, I’m planning on trying to get it up and
running on edge rails, and if it doesn’t break 1.0 compatibility then
committing it. If it does break 1.0 compatibility (which it
hopefully won’t), then I’ll hold off until 1.1 is officially released.


#3

Thanks Kevin. I just posted a similar question to the Rails list
before seeing your response. Sorry for the duplication.


#4

Today I got a panic from my server - filesystem is full on / I took a
look, even though I hadn’t added anything to /, and lo an behold I had
this in /root:

101648 -rw------- 1 root wheel 99M Mar 22 03:45 ruby18.core

How can I stop ruby from writing a core here, and/or how can I limit it
to a smaller size? In the Unix partitioning scheme they advocate a
small / partition for security, this mine is only 250Megs.

Thanks

P

http://fak3r.com - you dont have to kick it


#5

I believe this is a function of your shell. You can enable/disable it
using
the ulimit command in bash, the limit command in tcsh, or the rlimit
command
in ksh. This command will enable/disable it for that shell, not system
wide.

You can also use the limit command to change the max dump size. If you
run
‘ulimit -c 0’ in a bash shell, and something called from that shell
crashes,
you will get no dump.


#6

On Wed, 22 Mar 2006 14:25:11 -0500, “Ryan W.”
removed_email_address@domain.invalid wrote:

I believe this is a function of your shell. You can enable/disable it
using
the ulimit command in bash, the limit command in tcsh, or the rlimit
command
in ksh. This command will enable/disable it for that shell, not system
wide.

You are correct, in FreeBSD you can turn it off as you mentioned
(‘ulimit -c’), or modify it in /etc/login.conf for a global fix. Sorry
to post it here, I was just concerned since it was a normal user running
Typo, but it wrote the corefile out to /root.

Thanks

P