Typo on Dreamhost problems


I’m fairly new to Rails apps, but I’ve successfully hosted Redmine and
Instiki on Dreamhost subdomains without any problems.
I’m trying Typo, and I’ve tried 5.2 and 5.2.98 and I just cannot get
either to work.
At first I had that (forgive me as I didn’t write it down)
(Activesearch is 2.x and should be 1.x) error, which I fixed with the
local gem, but no matter what I do, I just get redirected to a rails
error page which says:

"Ruby on Rails application could not be started
The application has exited during startup (i.e. during the evaluation
of config/environment.rb). The error message may have been written to
the web server’s log file. Please check the web server’s log file
(i.e. not the (Rails) application’s log file) to find out why the
application exited. "

And then it gives the application root (which by the way, doesn’t give
the ‘public’ directory location, just the root of the application,
which I am assuming is correct.

All I do is wget the tarball and extract it, I tell dreamhost where
the public directory is (it uses mod_rails) and then copy
config/database.yml.example to config/database.yml, edit it with the
correct info, and I still get those errors.

As far as I can tell there is nothing about it in any of the logs I’ve
looked at/got access to.

I’d prefer to keep the URL private but can give it if it is required.

Does anyone have experience with hosting Typo 5.2+ on Dreamhost? Their
wiki entry for Typo is from 4.x or something, although I did try a gem
install as well with the same results.


Forgive the top post, but I got it sorted. I tried the typo install
again and then a rake gems:refresh_specs and this time it built the
database tables. Don’t have a clue why it worked this tie.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs