Typo, Mongrel, and non-root-urls

I’m trying to migrate my Typo installation at http://
H. Wade Minter – Carolina Hurricanes Public Address Announcer and Tech Executive. from Apache/FastCGI to Mongrel via Apache
proxies. The problem seems to be that Typo/Rails isn’t liking the
fact that Mongrel is running the blog at http://localhost:4001/ but
the Apache proxy isn’t at a root URL (/wade instead).

I’ve tried the reverse_proxy_fix plugin, but it doesn’t seem to be
working. I can go to the root of the website just fine, but if I try
to go to any other sub-URL (for example, http://www.lunenburg.org/
wade/articles/category/general), I get a “Page not found” error.

Is there any particular bit I need to twiddle, in environment.rb or
something, to get this to play nicely? Or do I need to fall back to

I’m running Typo SVN rev 1088.


I think non-root hosting with mongrel is still a bit tricky. I’ll
look at it once I’ve closed a few more bugs.

Alright - I’ve switched back to FastCGI for now. If you’ve got
anything you want me to test, let me know.


Anything in the new checkins that might affect Mongrel/proxies?

I haven’t dealt with mongrel-in-a-subdirectory yet, if that’s the
It used to be 1-line patch to Mongrel. I’ll see what I can do today or


Yeah, the situation is that Mongrel is serving up the app in the root
directory (localhost:4000), but Apache is proxying it from a
subdirectory (H. Wade Minter – Carolina Hurricanes Public Address Announcer and Tech Executive.), so that’s where the
issue comes up.

If there’s anything you need me to test, let me know.

I have a fix for this. Basically, I added a ‘–prefix’ flag to
mongrel_rails, along with a bit of plumbing. I sent it off to Zed a
few minutes ago; hopefully he’ll be okay with it.


Looks like the --prefix flag has made it into the newest release of
Mongrel, so I can now ditch FastCGI and sill run my blogs in a non-
root-URL namespace!

Thanks for the fix!