Typo / Dreamhost: strano problema

ciao a tutti,
sto deployando typo blog engine su dreamhost. Sul mio laptop ovviamente
va
tutto che e’ una meraviglia. Una volta deployato (su dreamhost), sia
usando
FCGI, sia usando Webrick alcune pagine non mi funzionano. In particolare
quelle che hanno a che fare con la sidebar (ribadisco: in locale tutto
funziona).
Per evitare problemi di ambiente/gem ho usato la versione full di typo
(da
svn) che comprende anche Rails e tutte le librerie connesse.
(/vendor/…).

Il log mi riporta questo errore :

ActionView::TemplateError (undefined method `[]’ for
#YAML::Syck::DomainType:0x41a052d0) on line #6 of
app/views/admin/sidebar/_active.rhtml:
3:

<%= active.description %>


4:

5:
<% active.class.fields.each do |row| -%>
6: <%= row.line_html(active) %>
7: <% end -%>

8: <%= link_to_remote(‘remove’,
9: :url => {:action => ‘remove’, :id => active.id,
app/models/sidebar.rb:27:in `input_html'
app/models/sidebar.rb:31:in `line_html'
#{RAILS_ROOT}/app/views/admin/sidebar/_active.rhtml:6:in

_run_rhtml_admin_sidebar__active' #{RAILS_ROOT}/app/views/admin/sidebar/_active.rhtml:5:ineach’
#{RAILS_ROOT}/app/views/admin/sidebar/_active.rhtml:5:in
_run_rhtml_admin_sidebar__active' vendor/rails/actionpack/lib/action_view/base.rb:316:insend’
vendor/rails/actionpack/lib/action_view/base.rb:316:in
compile_and_render_template' vendor/rails/actionpack/lib/action_view/base.rb:292:inrender_template’
vendor/rails/actionpack/lib/action_view/base.rb:251:in render_file' vendor/rails/actionpack/lib/action_view/base.rb:266:inrender’
vendor/rails/actionpack/lib/action_view/partials.rb:59:in
render_partial' vendor/rails/actionpack/lib/action_view/partials.rb:58:inbenchmark’
vendor/rails/actionpack/lib/action_view/partials.rb:58:in
render_partial' vendor/rails/actionpack/lib/action_view/partials.rb:73:inrender_partial_collection’
vendor/rails/actionpack/lib/action_view/partials.rb:71:in
`each_with_index’

vendor/rails/activerecord/lib/active_record/associations/association_proxy.rb:110:in
`each’

vendor/rails/activerecord/lib/active_record/associations/association_proxy.rb:110:in
`each_with_index’

vendor/rails/activerecord/lib/active_record/associations/association_proxy.rb:110:in
`send’

vendor/rails/activerecord/lib/active_record/associations/association_proxy.rb:110:in
`method_missing’

vendor/rails/activerecord/lib/active_record/associations/has_many_association.rb:90:in
method_missing' vendor/rails/actionpack/lib/action_view/partials.rb:71:inrender_partial_collection’
vendor/rails/actionpack/lib/action_view/base.rb:276:in render' #{RAILS_ROOT}/app/views/admin/sidebar/_actives.rhtml:4:in_run_rhtml_admin_sidebar__actives’
vendor/rails/actionpack/lib/action_view/base.rb:316:in `send’

grazie
-piero

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs