Typo 5.0.2 production installation themeing not working

Hi,

I installed typo with rails all worked well in development but once I
used production I no longer see my themes and mongrel spits out an error
about mkdir.

can anyone help me on this?

thanks

Hello,

Are you sure your perms are set properly and your webserver can write
on your public/ and tmp/ directories ?

Best regards
Frédéric

Le 20 janv. 08 à 09:55, Oren Zzz a écrit :

Hi,

Double checked it.
Yes

I am on a windows XP box.
I used both the gem install and the downloaded version.
both give me the same result

Hi,

I have attached the production log from typo.
also there is another thread of a user having the same problem:
http://typoforums.org/index.php/topic,275.0.html
His screenshot is what I see (except for the content).

Let me know if you need anything else :wink:

System Info

Ruby version 1.8.6 (i386-mswin32)
RubyGems version 1.0.1
Rails version 2.0.2
Active Record version 2.0.2
Action Pack version 2.0.2
Active Resource version 2.0.2
Action Mailer version 2.0.2
Active Support version 2.0.2
Database adapter sqlite3

Can you c/p your logs in a pastebin and send me the URL please, I’ll
have a look at this.

Le 20 janv. 08 à 10:04, Oren Zzz a écrit :

ok, I found the problem.

in file typo\app\controllers\theme_controller.rb at line 36

–> dst = “/#{page_cache_directory}/#{type}/theme/#{file}”

works when its changed to this
–> dst = “#{page_cache_directory}/#{type}/theme/#{file}”

without the ‘/’ before #{page_cache_directory}

this applies to Windows. I don’t know how it will work with other files
systems.

the default is for page_cache_directory is ‘RAILS_ROOT + “/public”’ as
defined in
RubyOnRails/lib/ruby/gems/1.8/doc/actionpack-2.0.2/rdoc/classes/ActionController/Caching/Pages.html.

is this a bug or is there an environment variable to handle this?

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs