Type image submit tags on IE dropping the params

I have noticed that on IE, the @params[:commit] does not come through on
image submit tags, but it does when the image is removed.

this fails:
<%= submit_tag( “Schedule”, {:type => “image”,
:src=>"/images/buttons/schedulecard.gif", :alt=>“Schedule Card”,
:class=>“button”})%>

but this works:
<%= submit_tag( “Schedule”, {:alt=>“Schedule Card”, :class=>“button”})%>

It seems as though the commit.x and commit.y will come through, is there
a
work around to have submit buttons show images here and still have the
@params[:commit] come through when posting from IE?


Regards,

Ian C.
349 Walden Street
Concord, MA 01742 USA
Direct Line: +1 (978) 6333372
Call Center Phone: +1 (714) 239 3875 (24 hrs)
Mobile Phone: +1 (617) 201 6463
Fax: +1(770) 818 5697
Suisse Phone: +41 (0) 22 548 1664
Skype: ian.connor

Ian C. wrote:

I have noticed that on IE, the @params[:commit] does not come through on
image submit tags, but it does when the image is removed.

this fails:
<%= submit_tag( “Schedule”, {:type => “image”,
:src=>"/images/buttons/schedulecard.gif", :alt=>“Schedule Card”,
:class=>“button”})%>

but this works:
<%= submit_tag( “Schedule”, {:alt=>“Schedule Card”, :class=>“button”})%>

Not really sure, but it looks like you’re using some old/deprecated
stuff. What version of Rails are you on? Try image_submit_tag instead of
submit_tag, and params instead of the old @params.

Chris K.
http://kampers.net

Thanks for the reply, it seems I was suffering this problem:

http://sbrew.typepad.com/software/2005/12/two_image_submi.html

On Jun 23, 8:55 pm, Chris K. [email protected]

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs