Turn off warning message on nginx

Hi,

Is there any command that i put in conf file to turnoff warning message
of joomla.

for instance in apache .htaccess if i add php_flag display_errors “0” it
doesnt show me error message anymore

how can i get rid of this problem

thanks in advance

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,172118,172118#msg-172118

On 02/04/2011 05:30 PM, lifeisjustabout wrote:

thanks in advance
This is php ‘thing’, nginx have nothing to do with it.

– Piotr.

I think Jerome was working on a fastcgi_param method to alter ini
directives from the nginx conf. IIRC.

for instance in apache .htaccess if i add php_flag display_errors “0” it
doesnt show me error message anymore

While nginx doesnt provide such option you can accomplish it with PHP
which
has exactly such feature for Fastcgi sapi -
http://www.php.net/manual/en/configuration.file.per-user.php

In short starting with 5.3.0 php you can put a ‘.user.ini’ file in
directory
containing ‘display_errors=0’ and it should work.

rr

it means for each requests, every directory from / to the full path of the
script file, a check is done on the presence of .user.ini. This kills
performances and should be avoid in high loaded sites.

While I’m not suggesting this (I don’t use it personally as no
coder/developer should override my carefully crafted server
configuration)
it is not as bad as you say .

If you had looked at the documentation (and as far I tested it also
works as
described) you might notice that there is ‘user_ini.cache_ttl’ which
controls how often are the ini files reread. Setting it high enough
(default
is 5 mins) won’t give you any penalty at all versus the flexibility such
approach provides.

“High loaded” sites wouldnt probably use .htaccess anyways which makes
me
think that the innitial poster doesnt really has one but asks for
similar
feature.

p.s. if you specifically do not disable (make an empty string ‘’ setting
for
user_ini.filename in your php.ini ) php does this by default …

rr

2011/2/9 Reinis R. [email protected]:

for instance in apache .htaccess if i add php_flag display_errors “0” it
doesnt show me error message anymore

While nginx doesnt provide such option you can accomplish it with PHP which
has exactly such feature for Fastcgi sapi -
http://www.php.net/manual/en/configuration.file.per-user.php

In short starting with 5.3.0 php you can put a ‘.user.ini’ file in directory
containing ‘display_errors=0’ and it should work.

it means for each requests, every directory from / to the full path of
the script file, a check is done on the presence of .user.ini. This
kills performances and should be avoid in high loaded sites.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs