Trying to upgrade

Hey all, I’m trying to upgrade my blog to 4.1, but I’m running into
some errors. Here’s the current one:

Making scripts executable
Checking database
Creating initial database
/usr/lib/ruby/gems/1.8/gems/activerecord-1.15.0/lib/active_record/connection_adapters/abstract_adapter.rb:128:in
log': Mysql::Error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '"article_id" integer DEFAULT NULL, (ActiveRecord::StatementInvalid) "tag_id" integer DEFAULT NULL )' at line 2: CREATE TABLE articles_tags ( "article_id" integer DEFAULT NULL, "tag_id" integer DEFAULT NULL ) from /usr/lib/ruby/gems/1.8/gems/activerecord-1.15.0/lib/active_record/connection_adapters/mysql_adapter.rb:243:inexecute’
from
/usr/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/lib/rails-installer/databases.rb:125:in
create' from /usr/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/lib/rails-installer/databases.rb:124:increate’
from
/usr/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/lib/rails-installer.rb:479:in
create_initial_database' from /usr/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/lib/rails-installer.rb:689:inin_directory’
from
/usr/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/lib/rails-installer.rb:478:in
create_initial_database' from /usr/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/lib/rails-installer.rb:213:ininstall_sequence’
from
/usr/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/lib/rails-installer.rb:192:in
install' from /usr/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/lib/rails-installer/commands.rb:95:incommand’
from
/usr/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/lib/rails-installer.rb:646:in
execute_command' from /usr/lib/ruby/gems/1.8/gems/typo-4.1/bin/typo:38 from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:489:inload’
from
/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:343:in
new_constants_in' from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:489:inload’
from /usr/bin/typo:18

Thanks in advance, I really don’t know where I should start on this
one. Just before this it was complaining about not finding a typo_dev
database, so I went ahead and created it, the typo_test one and then
added the existing user to those two and ran it again, getting this
error.

-warner


Warner O. - Programmer/Author
New book! Tapestry 101 available at http://sourcebeat.com/books/
tapestrylive.html
[email protected]
http://warneronstine.com/blog

Did you clear out your sessions from the database? Did you clear out
the
cache from disk?

-Linda

Ok, I somehow managed to upgrade, or so I thought. Now when I hit my
front-page I get this error:
Mysql::Error: Table ‘typo.articles_categories’ doesn’t exist: SELECT
contents.id AS t0_r0, contents.type AS t0_r1, contents.title AS
t0_r2, contents.author AS t0_r3, contents.body AS t0_r4,
contents.body_html AS t0_r5, contents.extended AS t0_r6,
contents.excerpt AS t0_r7, contents.keywords AS t0_r8,
contents.created_at AS t0_r9, contents.updated_at AS t0_r10,
contents.extended_html AS t0_r11, contents.user_id AS t0_r12,
contents.permalink AS t0_r13, contents.guid AS t0_r14,
contents.text_filter_id AS t0_r15, contents.whiteboard AS t0_r16,
contents.article_id AS t0_r17, contents.email AS t0_r18,
contents.url AS t0_r19, contents.ip AS t0_r20,
contents.blog_name AS t0_r21, contents.name AS t0_r22,
contents.published AS t0_r23, contents.allow_pings AS t0_r24,
contents.allow_comments AS t0_r25, contents.blog_id AS t0_r26,
contents.published_at AS t0_r27, contents.state AS t0_r28,
contents.status_confirmed AS t0_r29, categories.id AS t1_r0,
categories.name AS t1_r1, categories.position AS t1_r2,
categories.permalink AS t1_r3, tags.id AS t2_r0, tags.name AS
t2_r1, tags.created_at AS t2_r2, tags.updated_at AS t2_r3,
tags.display_name AS t2_r4, users.id AS t3_r0, users.login AS
t3_r1, users.password AS t3_r2, users.email AS t3_r3, users.name
AS t3_r4, users.notify_via_email AS t3_r5,
users.notify_on_new_articles AS t3_r6, users.notify_on_comments AS
t3_r7, users.notify_watch_my_articles AS t3_r8,
users.notify_via_jabber AS t3_r9, users.jabber AS t3_r10,
blogs.id AS t4_r0, blogs.settings AS t4_r1 FROM contents LEFT
OUTER JOIN articles_categories ON articles_categories.article_id =
contents.id LEFT OUTER JOIN categories ON categories.id =
articles_categories.category_id LEFT OUTER JOIN articles_tags ON
articles_tags.article_id = contents.id LEFT OUTER JOIN tags ON tags.id
= articles_tags.tag_id LEFT OUTER JOIN users ON users.id =
contents.user_id LEFT OUTER JOIN blogs ON blogs.id = contents.blog_id
WHERE (published = 1 AND contents.published_at < ‘2007-04-22 10:35:45’
AND blog_id = 1) AND ( (contents.type = ‘Article’ ) ) AND
contents.id IN (‘287’, ‘231’, ‘230’, ‘226’, ‘225’, ‘224’, ‘6’, ‘5’,
‘4’, ‘1’) ORDER BY contents.published_at DESC

And when I go to the login page I get a blank screen. Looking at the
code, the page is built but there is no login screen whatsoever.

-warner

On 4/22/07, Warner O. [email protected] wrote:

(ActiveRecord::StatementInvalid)
from /usr/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/lib/rails-installer.rb:479:in
`command’

New book! Tapestry 101 available at http://sourcebeat.com/books/
tapestrylive.html
[email protected]
http://warneronstine.com/blog


Warner O. - Programmer/Author
New book! Tapestry 101 available at http://sourcebeat.com/books/
tapestrylive.html
[email protected]
http://warneronstine.com/blog

I finally got this working by installing to a new directory and moving
over my db config (and some other configs I had done in the installer
directory). It was a pain to say the least but at least its up and
running again.

What appears to have happened is that it had upgraded the db fine but
something was still hanging around somewhere (I had completely removed
everything from the cache directory to no avail).

-warner

On 4/22/07, Linda D. [email protected] wrote:

Mysql::Error: Table ‘typo.articles_categories’ doesn’t exist: SELECT
contents.blog_name AS t0_r21, contents.name AS t0_r22,
users.notify_on_new_articles AS t3_r6, users.notify_on_comments AS
AND blog_id = 1) AND ( (contents.type = ‘Article’ ) ) AND

some errors. Here’s the current one:
“tag_id” integer DEFAULT NULL
`create’
689:in
/usr/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/lib/rails-installer.rb:
from /usr/lib/ruby/gems/1.8/gems/typo-4.1/bin/typo:38
es.rb:489:in


Warner O. - Programmer/Author
New book! Tapestry 101 available at http://sourcebeat.com/books/
tapestrylive.html
[email protected]
http://warneronstine.com/blog

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs