Trying to install win32-service gem


#1

I’m trying to install the rubygem for win32-service but can’t get it to
work. Here’s the command I use:

gem install win32-service --remote --include-dependencies --test

and the output is below. It says “Successfully installed” but then
gives an error. And when I try running the included tc_service.rb test
manually it fails.

Can someone please tell me what I’m doing wrong? Thanks in advance.

gem install win32-service --remote --include-dependencies --test
Attempting remote installation of ‘win32-service’
Updating Gem source index for: http://gems.rubyforge.org
Select which gem to install for your platform (i386-mswin32)

  1. win32-service 0.5.0 (mswin32)
  2. Cancel installation

1
Successfully installed win32-service-0.5.0-mswin32
Installing RDoc documentation for win32-service-0.5.0-mswin32…
c:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:204:in
report_activate_error': Could not find RubyGem win32-service (= 0.5.0) (Gem::LoadError) from c:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:141:inactivate’
from c:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:37:in
require_gem_with_options' from c:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:31:inrequire_gem’
from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/validator.rb:127:in unit_test' from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:222:inexecute’
from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:220:in
execute' from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:153:inexecute’
from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/command.rb:49:in
invoke' from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:94:inprocess_args’
from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:67:in run' from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:13:inrun’
from c:/ruby/bin/gem.bat:24