Trying to install using the typo script

Hi.

I’m trying to install typo on a shared host, and am having some issues.

first… i installed the required gems in my home directory… that
worked fine, and they all live in $HOME/ruby

but when I try to run “typo” to install the things I run into a
little problem.

$ ~/ruby/bin/typo
/usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:204:in
report_activate_error': Could not find RubyGem typo (> 0) (Gem::LoadError) from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:141:inactivate’
from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:37:in
require_gem_with_options' from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:31:inrequire_gem’

i’ve tried changing LOAD_PATH to various things in te ruby/ directory
with no joy.

any hints?

regards
Ian.

Scott had an example for shared host installation, make sure to check
out
his comment too…
http://scottstuff.net/blog/articles/2006/07/28/how-to-install-gems-when-youre-not-root

Thanks,
-Steve
http://www.stevelongdo.com

Thanks.

I was missing the GEM_PATH variable.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs