Trying to install Fox, FXRuby, and IFMapper on Mac OS X


#1

I can’t seem to find a specific answer on this…

I’m trying to install FXRuby, which apparently requires Fox to be
installed first, in order to run a Ruby program called IFMapper.

I’m running Mac OS X 10.5.6 and installed Ruby (though it does come
with the OS, so I’m not sure if that messed something up).

When I try to install Fox using this method:

I get this (last few lines)…

FXTIFImage.o .libs/FXTabBar.o .libs/FXTabBook.o .libs/
FXTabItem.o .libs/FXTable.o .libs/FXText.o .libs/FXTextCodec.o .libs/
FXTextField.o .libs/FXThread.o .libs/FXToggleButton.o .libs/
FXToolBar.o .libs/FXToolBarGrip.o .libs/FXToolBarShell.o .libs/
FXToolBarTab.o .libs/FXToolTip.o .libs/FXTopWindow.o .libs/
FXTranslator.o .libs/FXTreeList.o .libs/FXTreeListBox.o .libs/
FXTriStateButton.o .libs/FXUndoList.o .libs/FXURL.o .libs/
FXVec2d.o .libs/FXVec2f.o .libs/FXVec3d.o .libs/FXVec3f.o .libs/
FXVec4d.o .libs/FXVec4f.o .libs/FXVerticalFrame.o .libs/
FXVisual.o .libs/FXWindow.o .libs/FXWizard.o .libs/FXXBMIcon.o .libs/
FXXBMImage.o .libs/FXXPMIcon.o .libs/FXXPMImage.o .libs/
fxascii.o .libs/fxbmpio.o .libs/fxfilematch.o .libs/fxgifio.o .libs/
fxicoio.o .libs/fxiffio.o .libs/fxjpegio.o .libs/fxkeyboard.o .libs/
fxkeysym.o .libs/fxparsegeometry.o .libs/fxpcxio.o .libs/
fxpngio.o .libs/fxppmio.o .libs/fxpriv.o .libs/fxpsio.o .libs/
fxfsquantize.o .libs/fxezquantize.o .libs/fxwuquantize.o .libs/
fxrasio.o .libs/fxrgbio.o .libs/fxtargaio.o .libs/fxtifio.o .libs/
fxunicode.o .libs/fxutils.o .libs/fxxbmio.o .libs/fxxpmio.o .libs/
icons.o .libs/strtoll.o .libs/vsscanf.o -L/usr/X11/lib /usr/X11/lib/
libXext.6.4.0.dylib /usr/X11/lib/libXdmcp.6.0.0.dylib /usr/X11/lib/
libXau.6.0.0.dylib /usr/X11/lib/libX11.6.2.0.dylib /usr/X11/lib/
libXcursor.1.0.2.dylib /usr/X11/lib/libXrender.1.3.0.dylib /usr/X11/
lib/libXfixes.3.1.0.dylib /usr/X11/lib/libXrandr.2.0.0.dylib -ldl -
lpthread -lz -lbz2 -lm -lGLU -lGL -install_name /usr/local/lib/
libFOX-1.6.0.dylib -compatibility_version 1 -current_version 1.35
i686-apple-darwin9-g+±4.0.1: /usr/X11/lib/libXrandr.2.0.0.dylib: No
such file or directory
make[1]: *** [libFOX-1.6.la] Error 1
make: *** [install-recursive] Error 1

I tried to just “make” first then do “make install”, both using sudo
in front of them.

I’m very new to using Unix/X11 (started yesterday), so maybe I’m just
missing something basic, but would appreciate any help. Thanks.


#2

On Mon, Mar 16, 2009 at 3:37 PM, removed_email_address@domain.invalid wrote:

I’m trying to install FXRuby, which apparently requires Fox to be
installed first, in order to run a Ruby program called IFMapper.

I’m running Mac OS X 10.5.6 and installed Ruby (though it does come
with the OS, so I’m not sure if that messed something up).

The easiest way to do it if you’re using the built-in Ruby that comes
with Leopard is to install the precompiled binary gem for OS X. I’m
fairly sure that Apple also includes RubyGems with their Ruby
distribution, but you can check by typing:

gem --version

If you don’t have RubyGems installed, go take care of that first. Once
it’s set up, install the FXRuby gem for OS X:

sudo gem fxruby

And that should do the trick.

Hope this helps,

Lyle


#3

On Mar 16, 9:53 pm, Lyle J. removed_email_address@domain.invalid wrote:

distribution, but you can check by typing:
Hope this helps,

Lyle

Thanks for the help. I tried that, but it didn’t work. Do I need to
install Fox first because FXRuby relies on it (or maybe it’s just the
IFMapper that needs it?). I saw it somewhere that I needed it, but
can’t find it now.


#4

On Mar 16, 10:05 pm, removed_email_address@domain.invalid wrote:

sudo gem fxruby

can’t find it now.
Sorry, I wasn’t clear in the first post. That is actually Fox I’m
trying to install prior to FXRuby.


#5

kevin-p-kilburns-macbook:ifmapper-1.0.0 KPKilburn$ ruby ifmapper.rbw
/usr/local/lib/ruby/gems/1.8/gems/fxruby-1.6.19-universal-darwin-9/ext/
fox16/fox16.bundle: [BUG] Bus Error
ruby 1.8.6 (2007-03-13) [universal-darwin8.0]

Abort trap
kevin-p-kilburns-macbook:ifmapper-1.0.0 KPKilburn$- Hide quoted text -

  • Show quoted text -

I just tried to install Fox via MacPorts, but it still gives me an
error. I believe Fox Toolkit is the problem. I can’t get it compiled
for some reason.


#6

On Mar 16, 10:06 pm, removed_email_address@domain.invalid wrote:

I’m running Mac OS X 10.5.6 and installed Ruby (though it does come
it’s set up, install the FXRuby gem for OS X:
install Fox first because FXRuby relies on it (or maybe it’s just the
IFMapper that needs it?). I saw it somewhere that I needed it, but
can’t find it now.

Sorry, I wasn’t clear in the first post. That is actually Fox I’m
trying to install prior to FXRuby.

For completeness, I just tried to install fxruby with the gem and it
worked!

kevin-p-kilburns-macbook:fox-1.6.35 KPKilburn$ sudo gem install fxruby
Password:
Need to update 29 gems from http://gems.rubyforge.org

complete
Select which gem to install for your platform (universal-darwin8.0)

  1. fxruby 1.6.19 (universal-darwin-9)
  2. fxruby 1.6.19 (x86-mswin32-60)
  3. fxruby 1.6.19 (ruby)
  4. fxruby 1.6.18 (universal-darwin-9)
  5. fxruby 1.6.18 (x86-mswin32-60)
  6. fxruby 1.6.18 (ruby)
  7. Skip this gem
  8. Cancel installation

4
Successfully installed fxruby-1.6.18-universal-darwin-9
Installing ri documentation for fxruby-1.6.18-universal-darwin-9…
Installing RDoc documentation for fxruby-1.6.18-universal-darwin-9…

BUT…

I get this when I try to run my program (indicating that fox16 is
still needed???)…

kevin-p-kilburns-macbook:downloads KPKilburn$ cd ifmapper-1.0.0
kevin-p-kilburns-macbook:ifmapper-1.0.0 KPKilburn$ ls
HISTORY.txt IFMapper.rbw TODO.txt docs lib test
IFMapper.gemspec README.txt bin icons maps
kevin-p-kilburns-macbook:ifmapper-1.0.0 KPKilburn$ ruby ifmapper.rbw
/usr/local/lib/ruby/gems/1.8/gems/fxruby-1.6.19-universal-darwin-9/ext/
fox16/fox16.bundle: [BUG] Bus Error
ruby 1.8.6 (2007-03-13) [universal-darwin8.0]

Abort trap
kevin-p-kilburns-macbook:ifmapper-1.0.0 KPKilburn$


#7

On Mar 17, 10:28 am, removed_email_address@domain.invalid wrote:

/usr/local/lib/ruby/gems/1.8/gems/fxruby-1.6.19-universal-darwin-9/ext/
for some reason.- Hide quoted text -

  • Show quoted text -

Seems that this fixed the above problem:
http://www.nabble.com/Failed:-phase-compiling:-djvulibre-3.5.20-1001-failed-td16298018.html

But, I keep getting other errors.


#8

removed_email_address@domain.invalid wrote:

ruby 1.8.6 (2007-03-13) [universal-darwin8.0]

  • Show quoted text -
    which has lots of the same errors I’m encountering. Looks like I
    found the solutions (for now), so I’ll stop for now.

One thing to be aware of when dealing with Fox and FXRuby is that the
versions need to be the same. So FXRuby 1.6 will need Fox 1.6.
By the way, I have IFMapper installed with FXRuby 1.6 on Linux, so at
least you know it should work with it.

-Justin


#9

On Mar 17, 11:20 am, removed_email_address@domain.invalid wrote:

kevin-p-kilburns-macbook:ifmapper-1.0.0 KPKilburn$- Hide quoted text -

But, I keep getting other errors.- Hide quoted text -

  • Show quoted text -

Just in case anyone is following, I just found this blog
http://lylejohnson.name/blog/2007/12/01/building-fox-and-fxruby-on-mac-os-x-leopard/
which has lots of the same errors I’m encountering. Looks like I
found the solutions (for now), so I’ll stop for now.


#10

On Mar 17, 12:20 pm, Justin C. removed_email_address@domain.invalid wrote:

kevin-p-kilburns-macbook:downloads KPKilburn$ cd ifmapper-1.0.0

But, I keep getting other errors.- Hide quoted text -
By the way, I have IFMapper installed with FXRuby 1.6 on Linux, so at
least you know it should work with it.

-Justin- Hide quoted text -

  • Show quoted text -

Thanks for the info. I didn’t realize that they had to be the same.

I finally got it to work. Unfortunately, I don’t know exactly how.
There were several places where I got errors in libXrandr.2.0.0.dylib
(because it didn’t exist) and libGL.dylib (re-exports because it
existed in two places). Once I found the info on how to pass the
right parameters to it, it worked. It was a little trial and error,
so hopefully I can reproduce the results.

Another unfortunate mistake was that I didn’t compile FXRuby with the
PNG library. Why would I need that? IFMapper is the only thing I’ll
be using it for. Well, it seems that IFMapper uses PNG icons in it.

Oh well. Back to work.


#11

On Mar 16, 2009, at 3:37 PM, removed_email_address@domain.invalid wrote:

I can’t seem to find a specific answer on this…

I’m trying to install FXRuby, which apparently requires Fox to be
installed first, in order to run a Ruby program called IFMapper.

I’m running Mac OS X 10.5.6 and installed Ruby (though it does come
with the OS, so I’m not sure if that messed something up).

When I try to install Fox using this method:
http://davidrupp.blogspot.com/2008/01/installing-fox-and-fxruby-on-mac-os-x.html

This may not apply exactly, but here are notes to myself from the last
time I tried to install fxri (using macports). These instructions are
old, so you a) could probably use Leopard’s version of ruby and b)
could probably use newer versions. Anyway, I hope this helps:

$ sudo port install ruby
$ sudo port install fox
$ sudo port install fxscintilla

Here are the versions I’ve got:

$ port installed ruby fox fxscintilla
The following ports are currently installed:
ruby @1.8.4_2 (active)
fox @1.2.13_1 (active)
fxscintilla @1.63_0+darwin_8 (active)

$ sudo gem install fxruby – --with-fox-include=/opt/local/include/
fox-1.2 --with-fox-lib=/opt/local/lib --with-fxscintilla-include=/opt/
local/include/fxscintilla --with-fxscintilla-lib=/opt/local/lib

(I selected fxruby version 1.2.6 instead of 1.4.4 since I have fox 1.2
instead of 1.4 installed). Then build and install fxruby (1.2.6 - the
same version as the gem) from source (yes, this is necessary):

$ ruby install.rb config – --with-fox-include=/opt/local/include/
fox-1.2 --with-fox-lib=/opt/local/lib --with-fxscintilla-include=/opt/
local/include/fxscintilla --with-fxscintilla-lib=/opt/local/lib
$ ruby install.rb setup
$ sudo ruby install.rb install
$ sudo gem install fxri


#12

$ ruby install.rb config – --with-fox-include=/opt/local/include/
fox-1.2 --with-fox-lib=/opt/local/lib --with-fxscintilla-include=/opt/
local/include/fxscintilla --with-fxscintilla-lib=/opt/local/lib
$ ruby install.rb setup
$ sudo ruby install.rb install
$ sudo gem install fxri

Thanks for the help. I finally got it working. Seems that Leopard
has some issues that need to be addressed.