Trying to find a stable copy of the FPGA code for the USRP2

Hi

I am looking for a stable copy of the FPGA code for the USRP2 board. I
have
tried the code that come when you run the command
git clone git://git.ettus.com/ettus/fpga.git The builds fine Xilinx ISE
12.2
but when it copy it onto the SD card and try run the build on the USRP2
board I only get LED F turning on and when i run the command find_usrp
it
dose not find the board. If anyone knows where I can get a stable
release of
the FPGA code it would be great. Please note that I don’t know my way
around
with the git commands so if you please give full command line inputs
with
would be great.

Regards
Alan Jones
Master Student in the RRSG Research Group
University of Cape Town

Hello,

you can find the newest code (for the UHD driver) here:
http://ettus-apps.sourcerepo.com/redmine/ettus/projects/uhd/wiki

You can also find a tool with graphical user interface in host/utils to
flash the card.

The link
git.ettus.com/ettus/fpga.git
should be correct with the “raw ethernet” host driver, but I think it is
included in the UHD repo above as well, so the UHD repository is
recommended.

LED “D” indicates that the firmware is up and running, if it does not
light up it means that (i) the FPGA is not set up or (ii) that the
firmware is not running.

The problem is probably an error on the SD card. Several issues come to
mind here:

  • both firmware and FPGA bitstream must be flashed on the card. That is,
    txrx.bin and u2_rev3.bin. You have to use the flash tool twice.
  • SDHC card are not supported, they must be SD.
  • you must flash directly to the beginning of the card, so use /dev/sdX
    instead of /dev/sdX{1,2,3,4,…}. This nukes the filesystem and
    (possibly) the master boot record, so you cannot have other data on the
    SD card, and old data will disappear.
  • mismatch between FPGA and firmware version (but this leads mostly to
    strange behavior)

I have posted more info some weeks ago, and there is a wiki page with
more info:
http://gnuradio.org/redmine/wiki/1/USRP2UserFAQ#How-do-I-change-the-firmware-and-FPGA-code-on-the-SD-Card

Regards,
Matthias

Am 18.10.2010 um 14:17 schrieb Alan Jones:

If you are using ISE12.x you need to use the ise12 branch in git. Go
into the repo and type:

git co ise12

Then do a make clean and make bin.

Matt

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs