Trying to create new radiant install from trunk, getting error from `database_configuration'

So far I’ve done the following:

  1. svn co http://svn.radiantcms.org/radiant/trunk/radiant radiant65
  2. created database.yml file and added my production info

Macintosh-2:radiant65 jared$ rake production db:bootstrap --trace
(in /Users/jared/Documents/programming/rails/radiant/radiant65)
** Invoke production (first_time)
** Execute production
** Invoke environment (first_time)
** Execute environment
rake aborted!
syntax error on line 23, col 11: ' /usr/local/lib/ruby/1.8/yaml.rb:133:inload’
/usr/local/lib/ruby/1.8/yaml.rb:133:in load' /Users/jared/Documents/programming/rails/radiant/radiant65/vendor/ rails/railties/lib/initializer.rb:506:indatabase_configuration’
/Users/jared/Documents/programming/rails/radiant/radiant65/vendor/
rails/railties/lib/initializer.rb:233:in initialize_database' /Users/jared/Documents/programming/rails/radiant/radiant65/vendor/ rails/railties/lib/initializer.rb:94:inprocess’
/Users/jared/Documents/programming/rails/radiant/radiant65/vendor/
rails/railties/lib/initializer.rb:49:in send' /Users/jared/Documents/programming/rails/radiant/radiant65/vendor/ rails/railties/lib/initializer.rb:49:inrun’
/Users/jared/Documents/programming/rails/radiant/radiant65/lib/radiant/
initializer.rb:89:in run' /Users/jared/Documents/programming/rails/radiant/radiant65/config/ environment.rb:12 /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:ingem_original_require’
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require’

Since I have 2.0.2 installed locally, I deleted /vendor/rails and
tried again

Macintosh-2:radiant65 jared$ rake production db:bootstrap --trace
(in /Users/jared/Documents/programming/rails/radiant/radiant65)
** Invoke production (first_time)
** Execute production
** Invoke environment (first_time)
** Execute environment
rake aborted!
syntax error on line 21, col 11: ' /usr/local/lib/ruby/1.8/yaml.rb:133:inload’
/usr/local/lib/ruby/1.8/yaml.rb:133:in load' /usr/local/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/initializer.rb: 506:indatabase_configuration’
/usr/local/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/initializer.rb:
233:in initialize_database' /usr/local/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/initializer.rb:94:inprocess’
/usr/local/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/initializer.rb:49:in
send' /usr/local/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/initializer.rb:49:inrun’
/Users/jared/Documents/programming/rails/radiant/radiant65/lib/radiant/
initializer.rb:89:in run' /Users/jared/Documents/programming/rails/radiant/radiant65/config/ environment.rb:12 /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:ingem_original_require’
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require’

I’ve looked in the various files it mentions but don’t see anything
wrong at the lines it mentions. Anyone have have any pointers?

Restore vendor/rails, as Radiant is always tied to a specific Rails
version. The error is in your database.yml file, probably line 23,
column 11 as the error says.

Sean

Sorry, didn’t realize you replied. I did check the file and everything
looked fine…then I sent the email and of course found the answer 30
seconds later. I looked in an old config file and realized what was
missing, the host: entry. I used the one from trunk and filled in my
values, I didn’t even bother checking if they were all there.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs