Trying to add bootstrap to existing project, getting CSS compile error: missing file

Trying to add bootstrap to an app being ported to Rails 3.2.3.

I get the following error:

Error compiling asset application.css:
Sass::SyntaxError: File to import not found or unreadable: bootstrap.

Here’s my gem file:

source ‘http://rubygems.org

gem ‘rails’, ‘3.2.9’

group :assets do
gem ‘sass-rails’, ‘~> 3.1’
gem ‘bootstrap-sass’, ‘~> 2.0.0’
gem ‘coffee-rails’, ‘~> 3.2.2’
gem ‘uglifier’, ‘>= 1.2.3’

end

gem ‘mysql2’,‘0.2.6’

gem ‘mysql2’,‘0.3.11’
gem ‘acts-as-taggable-on’
#gem “will_paginate”, :git =>
‘git://github.com/mislav/will_paginate.git’,
:branch => ‘rails3’
gem ‘kaminari’
gem “jquery-rails”
gem “annotate”
gem “bcrypt-ruby”, :require => “bcrypt”

The bootstrap gem install with no errors, but I can’t see where it
install
any files in the
rails application directory tree.

I’m really stumped by this.

Thanks,

Joe

On Thu, Jan 3, 2013 at 4:31 AM, jmcguckin [email protected] wrote:

Trying to add bootstrap to an app being ported to Rails 3.2.3.

group :assets do
gem ‘sass-rails’, ‘~> 3.1’
gem ‘bootstrap-sass’, ‘~> 2.0.0’
gem ‘coffee-rails’, ‘~> 3.2.2’
gem ‘uglifier’, ‘>= 1.2.3’

end

I have bootstrap-sass outside of group :assets and it’s working fine…

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs