Troubleshooting "undefined class/module"


#1

I’m having a bit of a headbanger here… maybe someone can help.

A class in a fairly complicated existing Rails app that I’m working on
seems intermittently not to load.
The error is basically the following:

undefined class/module InnerPackage

c:/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.0/lib/action_controller/session/active_record_store.rb:75:in
load' c:/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.0/lib/action_controller/session/active_record_store.rb:75:inunmarshal’
c:/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.0/lib/action_controller/session/active_record_store.rb:116:in
data' c:/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.0/lib/action_controller/session/active_record_store.rb:126:inmarshal_data!’
c:/ruby/lib/ruby/gems/1.8/gems/activerecord-1.13.0/lib/active_record/callbacks.rb:333:in
send' c:/ruby/lib/ruby/gems/1.8/gems/activerecord-1.13.0/lib/active_record/callbacks.rb:333:incallback’
c:/ruby/lib/ruby/gems/1.8/gems/activerecord-1.13.0/lib/active_record/callbacks.rb:330:in
each' c:/ruby/lib/ruby/gems/1.8/gems/activerecord-1.13.0/lib/active_record/callbacks.rb:330:incallback’
c:/ruby/lib/ruby/gems/1.8/gems/activerecord-1.13.0/lib/active_record/callbacks.rb:248:in
`create_or_update’

I’ve seen this happen if the controller file has a syntax error, but
that’s not it. I’m interested mostly hearing a debugging approach that
I haven’t tried, or if you’ve banged your head on this one before, what
you learned in doing so.

The model file is in app_root/app/models
The problem is intermittent, and goes away for a while if I restart
WEBrick