Troubles with Mephisto


#1

Hi,

I am having trouble creating a new article on Mephisto on my Dreamhost
server. I am using Rails 2.0.2 and Mephisto 0.8.

When I login to the admin area and then attempt to create a new
article I see this error in my log

Code : - fold - unfold

  1. Parameters: {“action”=>“new”, “controller”=>"admin/article
  2. s"}
  3. LoadError (Expected /mnt/local/home/app/models/asset.rb to
    define Asset):
  4. /vendor/rails/activesupport/lib/active_support/dependenc
    
  5. ies.rb:249:in `load_missing_constant’
  6. /vendor/rails/activesupport/lib/active_support/dependenc
    
  7. ies.rb:453:in `const_missing’
  8. /vendor/rails/activesupport/lib/active_support/dependenc
    
  9. ies.rb:465:in `const_missing’
  10. /vendor/rails/activesupport/lib/active_support/dependenc
    
  11. ies.rb:260:in `load_missing_constant’
  12. /vendor/rails/activesupport/lib/active_support/dependenc
    
  13. ies.rb:469:in `const_missing’
  14. /vendor/rails/activerecord/lib/active_record/base.rb:175
    
  15. 0:in `compute_type’
  16. /vendor/rails/activerecord/lib/active_record/reflection.
    
  17. rb:125:in `send’
  18. /vendor/rails/activerecord/lib/active_record/reflection.
    
  19. rb:125:in `klass’
  20. /vendor/rails/activerecord/lib/active_record/association
    
  21. s/has_many_association.rb:152:in `construct_sql’
  22. /vendor/rails/activerecord/lib/active_record/association
    
  23. s/has_many_association.rb:6:in `initialize’
  24. /vendor/rails/activerecord/lib/active_record/association
    
  25. s.rb:1032:in `new’

Having google’d the problem I found these two links (below), but
neither solved the problem.
http://groups.google.com/group/Mephisto … 4f4885f6f2
http://www.marcinciszak.com/tags/blog

Has anybody come across this issues and know the solution?

Thanks,
Edwin