Trouble with setting up RoR and starting new projects

I’m totally new to Ruby + RoR (coming from C++). This is my first project I’m trying to launch . The steps I’ve taken was to make a dir for my project Blog by using rails new Blog

Can anyone point me to the right direction with solving this issue? sqlite3 isn’t installing and I’ve manually installed it as per hinted by the cmd which didn’t help the situation.

You have to install sqlite3 so your gem can field sqlite3.h file
please use this link to install sqlite on windows

I’ve already downloaded sqlite3 manually and path’d it properly as that was my first instinct to getting around this issue. I can run sqlite3 commands on cmd properly which confirms it’s installed on my system, but I still run into the same error with Rails specifically

The error is telling your that you don’t have the sqlite3 headers and libs that are required to install sqlite3 gem from source. Even as your have installed it but gem installation could not find it. Can you try following command as a solution but remember your need to replace paths as per your installation

gem install sqlite3 --platform=ruby -- --with-sqlite3-dir=C:/path/to/sqlite3

I am new on this forum, so not sure what are norms to give answers and help, please correct me if I am doing anything out of norms. The path you should have helper file
please check following site for more details

follow this link once,this tells you right diercection of creating basic application, from this may be your problem will solve

I’m still receiving the same error sadly, I believe it’s a mingw issue. I’ve switched over to using WSL2 and my RoR environment is working perfectly! :slight_smile:

I appreciate the advice you’ve given!

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs