Trouble with latest gem typo

Dear list,

I´m running latest gem installable Typo. I had a
“Application error (Rails)” from the typo version I had running.
So I hoped running the following would get me back on track:

gem update typo; gem install typo . ;
cp …/oldworking-typo/config/database.yml config/;
typo start .

But I still get the Application error (Rails) message. Did a rake
db:migrate without sucsess.

When trying to access myhost:4547/admin, I get redirected to
http://myhost:4547/admin/general/update_database

the log says this:

Processing GeneralController#update_database (for 195.159.113.10 at
2007-02-02 21:44:17) [GET]
Session ID: a9cf2317dc5a376ae8e5e854e81d6bec
Parameters: {“action”=>“update_database”,
“controller”=>“admin/general”}

NoMethodError (undefined method collect' for nil:NilClass): /app/controllers/admin/general_controller.rb:18:inupdate_database’
/vendor/rails/actionpack/lib/action_controller/base.rb:941:in send' /vendor/rails/actionpack/lib/action_controller/base.rb:941:inperform_action_without_filters’
/vendor/rails/actionpack/lib/action_controller/filters.rb:368:in
perform_action_without_benchmark' /vendor/rails/actionpack/lib/action_controller/benchmarking.rb:69:inperform_action_without_rescue’
/usr/lib/ruby/1.8/benchmark.rb:293:in measure' /vendor/rails/actionpack/lib/action_controller/benchmarking.rb:69:inperform_action_without_rescue’
/vendor/rails/actionpack/lib/action_controller/rescue.rb:82:in
perform_action' /vendor/rails/actionpack/lib/action_controller/base.rb:408:insend’
/vendor/rails/actionpack/lib/action_controller/base.rb:408:in
process_without_filters' /vendor/rails/actionpack/lib/action_controller/filters.rb:377:inprocess_without_session_management_support’
/vendor/rails/actionpack/lib/action_controller/session_management.rb:117:in
process' /vendor/rails/railties/lib/dispatcher.rb:38:indispatch’
/usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel/rails.rb:78:in
process' /usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel/rails.rb:76:insynchronize’
/usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel/rails.rb:76:in
process' /usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel.rb:618:inprocess_client’
/usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel.rb:617:in
each' /usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel.rb:617:inprocess_client’
/usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel.rb:736:in
run' /usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel.rb:736:ininitialize’
/usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel.rb:736:in
new' /usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel.rb:736:inrun’
/usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel.rb:720:in
initialize' /usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel.rb:720:innew’
/usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel.rb:720:in
run' /usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel/configurator.rb:271:inrun’
/usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel/configurator.rb:270:in
each' /usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel/configurator.rb:270:inrun’
/usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/bin/mongrel_rails:127:in
run' /usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel/command.rb:211:inrun’
/usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/bin/mongrel_rails:243
/usr/bin/mongrel_rails:18:in `load’
/usr/bin/mongrel_rails:18

I ran rake db:migrate afterward, just to make sure.
Any suggestions to how to get my blog up running again?

All help is highly appreciated!

Best regards,
Martin S.

ActiveRecord::StatementInvalid: Mysql::Error: Unknown column ‘url’ in
‘field list’: INSERT INTO contents (updated_at, body, guid,
published, url, author, type, id, blog_id, published_at,
article_id, state, created_at, email) VALUES (‘2004-05-02
20:00:02’, ‘Comment body italic bold’, ‘b1i2n3g4o5t6i7v’, 1,
www.google.com’, ‘John Bar’, ‘Comment’, 15, 1, ‘2004-05-02 20:00:02’,
14, ‘ContentState::Ham’, ‘2004-05-02 20:00:02’, ‘[email protected]’)
/home/martins/public_html/typo-current/temp/gemtest/config/…/vendor/rails/activerecord/lib/active_record/connection_adapters/abstract_adapter.rb:120:in
log' /home/martins/public_html/typo-current/temp/gemtest/config/../vendor/rails/activerecord/lib/active_record/connection_adapters/mysql_adapter.rb:184:inexecute’
/home/martins/public_html/typo-current/temp/gemtest/config/…/vendor/rails/activerecord/lib/active_record/fixtures.rb:288:in
insert_fixtures' /home/martins/public_html/typo-current/temp/gemtest/config/../vendor/rails/activerecord/lib/active_record/fixtures.rb:287:ineach’
/home/martins/public_html/typo-current/temp/gemtest/config/…/vendor/rails/activerecord/lib/active_record/fixtures.rb:287:in
insert_fixtures' /home/martins/public_html/typo-current/temp/gemtest/config/../vendor/rails/activerecord/lib/active_record/fixtures.rb:257:increate_fixtures’
/home/martins/public_html/typo-current/temp/gemtest/config/…/vendor/rails/activerecord/lib/active_record/fixtures.rb:257:in
each' /home/martins/public_html/typo-current/temp/gemtest/config/../vendor/rails/activerecord/lib/active_record/fixtures.rb:257:increate_fixtures’
/home/martins/public_html/typo-current/temp/gemtest/config/…/vendor/rails/activerecord/lib/active_record/connection_adapters/abstract/database_statements.rb:51:in
transaction' /home/martins/public_html/typo-current/temp/gemtest/config/../vendor/rails/activerecord/lib/active_record/fixtures.rb:255:increate_fixtures’
/home/martins/public_html/typo-current/temp/gemtest/config/…/vendor/rails/activerecord/lib/active_record/base.rb:794:in
silence' /home/martins/public_html/typo-current/temp/gemtest/config/../vendor/rails/activerecord/lib/active_record/fixtures.rb:248:increate_fixtures’
/home/martins/public_html/typo-current/temp/gemtest/config/…/vendor/rails/activerecord/lib/active_record/fixtures.rb:565:in
load_fixtures' /home/martins/public_html/typo-current/temp/gemtest/config/../vendor/rails/activerecord/lib/active_record/fixtures.rb:512:insetup_with_fixtures’
/home/martins/public_html/typo-current/temp/gemtest/config/…/vendor/rails/activerecord/lib/active_record/fixtures.rb:547:in
`setup’

  1. Error:
    test_xml_atom10(XmlControllerTest):
    ActiveRecord::StatementInvalid: Mysql::Error: Unknown column ‘url’ in
    ‘field list’: INSERT INTO contents (updated_at, body, guid,
    published, url, author, type, id, blog_id, published_at,
    article_id, state, created_at, email) VALUES (‘2004-05-02
    20:00:02’, ‘Comment body italic bold’, ‘b1i2n3g4o5t6i7v’, 1,
    www.google.com’, ‘John Bar’, ‘Comment’, 15, 1, ‘2004-05-02 20:00:02’,
    14, ‘ContentState::Ham’, ‘2004-05-02 20:00:02’, ‘[email protected]’)
    /home/martins/public_html/typo-current/temp/gemtest/config/…/vendor/rails/activerecord/lib/active_record/connection_adapters/abstract_adapter.rb:120:in
    log' /home/martins/public_html/typo-current/temp/gemtest/config/../vendor/rails/activerecord/lib/active_record/connection_adapters/mysql_adapter.rb:184:inexecute’
    /home/martins/public_html/typo-current/temp/gemtest/config/…/vendor/rails/activerecord/lib/active_record/fixtures.rb:288:in
    insert_fixtures' /home/martins/public_html/typo-current/temp/gemtest/config/../vendor/rails/activerecord/lib/active_record/fixtures.rb:287:ineach’
    /home/martins/public_html/typo-current/temp/gemtest/config/…/vendor/rails/activerecord/lib/active_record/fixtures.rb:287:in
    insert_fixtures' /home/martins/public_html/typo-current/temp/gemtest/config/../vendor/rails/activerecord/lib/active_record/fixtures.rb:257:increate_fixtures’
    /home/martins/public_html/typo-current/temp/gemtest/config/…/vendor/rails/activerecord/lib/active_record/fixtures.rb:257:in
    each' /home/martins/public_html/typo-current/temp/gemtest/config/../vendor/rails/activerecord/lib/active_record/fixtures.rb:257:increate_fixtures’
    /home/martins/public_html/typo-current/temp/gemtest/config/…/vendor/rails/activerecord/lib/active_record/connection_adapters/abstract/database_statements.rb:51:in
    transaction' /home/martins/public_html/typo-current/temp/gemtest/config/../vendor/rails/activerecord/lib/active_record/fixtures.rb:255:increate_fixtures’
    /home/martins/public_html/typo-current/temp/gemtest/config/…/vendor/rails/activerecord/lib/active_record/base.rb:794:in
    silence' /home/martins/public_html/typo-current/temp/gemtest/config/../vendor/rails/activerecord/lib/active_record/fixtures.rb:248:increate_fixtures’
    /home/martins/public_html/typo-current/temp/gemtest/config/…/vendor/rails/activerecord/lib/active_record/fixtures.rb:565:in
    load_fixtures' /home/martins/public_html/typo-current/temp/gemtest/config/../vendor/rails/activerecord/lib/active_record/fixtures.rb:512:insetup_with_fixtures’
    /home/martins/public_html/typo-current/temp/gemtest/config/…/vendor/rails/activerecord/lib/active_record/fixtures.rb:547:in
    `setup’

210 tests, 192 assertions, 0 failures, 151 errors
rake aborted!
Test failures

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs