Trouble with install of 2.3.9 due to rake requires version of ruby > 1.9

hey all

i am trying to install rails into a new computer with rvm.

i have installed ruby 1.8.7
and rubygems 1.3.7 --force

these are both versions that i must have to run my website.
the problem is that when i try to install rails with* gem install
–version
2.3.9 rails*

i get the following error.

ERROR: Error installing rails:

  • rake requires Ruby version >= 1.9.*

It’s nuts, i have followed this exact procedure before, and it installed
just fine.
in fact, my website is now running with 1.8.7 ruby, 2.3.9 rails, and
with
rubygems 1.3.7

any tips on how to get around this would be greatly appreciated.

thanks

skrite wrote in post #1140917:

hey all

i am trying to install rails into a new computer with rvm.

i have installed ruby 1.8.7
and rubygems 1.3.7 --force

these are both versions that i must have to run my website.
the problem is that when i try to install rails with* gem install
–version
2.3.9 rails*

i get the following error.

ERROR: Error installing rails:

  • rake requires Ruby version >= 1.9.*

It’s nuts, i have followed this exact procedure before, and it installed
just fine.
in fact, my website is now running with 1.8.7 ruby, 2.3.9 rails, and
with
rubygems 1.3.7

any tips on how to get around this would be greatly appreciated.

thanks

Did you try downgrading rake? I work on a similar environment and there
we keep rake to 0.9.2.2, which has been the most problem free version we
could find for Ruby 1.8.7.

make sure to remove rake from the rvm gemset. You might need to do

rvm @global do gem uninstall rake

if rake is in the global gemset.

looks like that worked, i installed rake version 0.9.2.2 and then was
able
to install rails 2.3.9
thanks very much for your help
sk

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs