Trouble with Capybara and RSpec on a new model spec


#1

I have searched a lot for a solution, but I could not find it! I am
trying to make a rails application after watching Michael H.'s
tutorial and when i fill data manually and submit it nothing happens and
nothing records in the Mailers table and I am facing the following
error:

Failures:

  1. Mailer pages mail us with valid information should send a mail
    Failure/Error: expect { click_button submit}.to change(Mailer,
    :count).by(1)
    count should have been changed by 1, but was changed by 0

    ./spec/requests/mailer_pages_spec.rb:31:in `block (4 levels) in

<top (required)>’

Finished in 0.89134 seconds
2 examples, 1 failure

Failed examples:

rspec ./spec/requests/mailer_pages_spec.rb:30 # Mailer pages mail us
with valid information should send a mail

Randomized with seed 17352

The model file is:

class Mailer < ActiveRecord::Base
attr_accessible :company_name, :contact_name, :address, :telephone,
:email, :description
before_save { |mailer| mailer.email = mailer.email.downcase }
validates :company_name, length: { maximum: 50 }
validates :contact_name, presence: true, length: { maximum: 40 }
VALID_EMAIL_REGEX = /\A[\w+-.]+@[a-z\d-.]+.[a-z]+\z/i
validates :email, presence: true, format: { with: VALID_EMAIL_REGEX }
end

Controller:

class MailersController < ApplicationController

def new
@mailer = Mailer.new
end

def create
@mailer = Mailer.new(params[:mailer])
if @mailer.save
redirect_to root_path
else
render ‘new’
end
end
end

Integration test:

require ‘spec_helper’

describe “Mailer pages” do

subject { page }

describe “mail us” do

 let(:submit) { "Send my Mail"}
 before { visit mailers_path }


 describe "with invalid information" do
   it "should not send a mail" do
     expect { click_button submit }.not_to change(Mailer, :count)
     end
 end

 describe "with valid information" do
   before do
     fill_in "Company name", with: "Mailer Company"
     fill_in "Contact name", with: "Mailer Contact"
     fill_in "Address",      with: "Mailer Address"
     fill_in "Telephone",    with: "123-456-789"
     fill_in "Email",        with: "removed_email_address@domain.invalid"
     fill_in "Description",  with: "something to say"
   end

   it "should send a mail" do
     expect { click_button submit}.to change(Mailer, :count).by(1)
   end
 end

end
end

And the form:

<% provide(:title , ‘Mail Us’) %>

Mail Us

<%= form_for(@mailer) do |f| %>
<%= f.label :company_name %>
<%= f.text_field :company_name %>

<%= f.label :contact_name %>
<%= f.text_field :contact_name %>

<%= f.label :address %>
<%= f.text_field :address %>

<%= f.label :telephone %>
<%= f.text_field :telephone %>

<%= f.label :email %>
<%= f.text_field :email %>

<%= f.label :description %>
<%= f.text_field :description %>

<%= f.submit "Send my Mail", class: "btn btn-large btn-primary"%>

<% end %>


#2

Hi All,
Iam new to ruby application having little knowledge,and currently am
working for a testing application which is designed on
Ruby,capybara,rspec and am having an issue i.e when am click on a
button a javascript popup is displaying and sometime modalpopup also
displaying but am unable to click the alert and even i have tried
different ways with the help of google but none of them worked, for
example the script which i have used for clicking the alert is below

1.alert=page.driver.browser.switch_to.alert
alert.send(‘Stay on Page’)

  1. page.evaluate_script(‘window.confirm = function() { return true; }’)
    page.click(“Stay on Page”)

Coming to my frame work we have four files

  1. Testcase.rb file—here the logic which test case required which
    looks like following for details find in the attachment
    require ‘spec_helper’
    feature ‘Brochure Sample’ do
    #Config changes
    app = Application.new
    #Specify Object Maps
    scenario ‘Apply To All Levels Sample Messages’ do
    begin
    app.utilities.setup_directory(‘Apply To All Levels Sample Messages’)
    #Specify Test data
    #Launch the web site, and open Application
    rescue Exception => e
    app.utilities.capture_screen_shot(‘script failed’,‘fail’)
    raise e
    end
    end
    end

2.class file
The methods required for the test case
3. Spec Helpers
This contains some configuration i.e about drivers it looks like the
below for details find the attachment

require ‘capybara’
require ‘capybara/rspec’
require ‘capybara/dsl’
require ‘selenium-webdriver’
require ‘yaml’
#require ‘capybara-screenshot/rspec’

Capybara.default_driver = :selenium
Capybara.run_server = false

See http://rubydoc.info/gems/rspec-core/RSpec/Core/Configuration

RSpec.configure do |config|
config.include Capybara::DSL
config.include Capybara::RSpecMatchers
config.treat_symbols_as_metadata_keys_with_true_values = true
config.run_all_when_everything_filtered = true
config.filter_run :focus
#Capybara configuration changes from the default that are needed.
Capybara.configure do |config|
config.match = :prefer_exact
config.exact_options = true
config.ignore_hidden_elements = true
config.visible_text_only = true
end

end

require_relative ‘configuration’
require_relative ‘helpers/common/application’

#this recursively pulls all files under the ‘helpers’ folder.
#puts ‘Current Directory:-’ + File.dirname(FILE)
#puts [File.join(File.dirname(FILE), ‘helpers’, '.rb’)]
current_path = File.expand_path File.dirname(FILE)
#puts “CURRENT” + current_path
helpers_path = File.join current_path, “helpers”
#puts “HELPERS” + helpers_path
Dir["#{helpers_path}/**/
.rb"].each { |file|
require file
#puts file
}

4.common
This is about utility i.e. the common methods used in the project
5.configuration
This contains the required urls,credentials etc

so can anyone please help me for clicking the alerts,modalpopups what
are the changes that i need to do for my framework please guide for
solving this issue