Trouble with capistrano "disable_web" task on litespeed

Hi,

When I run the capistrano “disable_web” task, the file
maintenance.html is copied into #{shared_path}/system directory.

The symlink in application’s public directory that points to a
#{shared_path}/system directory works fine, because when I go to the
url http://myhost/system/maintenance.html the maintenance page is
showed.

Also I added the rewrite rules to my Virtual Host:
RewriteCond %{DOCUMENT_ROOT}/system/maintenance.html -f
RewriteCond %{SCRIPT_FILENAME} !maintenance.html
RewriteRule ^.*$ /system/maintenance.html [L]

But when I go to my application http://myhost the maintenance page
isn’t showed, instead the application is displayed right

any clue?

RewriteCond %{SCRIPT_FILENAME} !maintenance.html
RewriteRule ^.*$ /system/maintenance.html [L]

But when I go to my application http://myhost the maintenance page
isn’t showed, instead the application is displayed right

any clue?

Any chance that “Enable Rewrite” is set to no? At the top of the
“Rewrite” tab for your virtual host?

That’s the only thing I can think of… either that or litespeed isn’t
setting those %{} like you think they are.

Philip,

Yes, the problem was in value on %{DOCUMENT_ROOT}

I changed to the full path and works fine

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs