Trouble starting the server, HELP PLEASE!

can anybody tell me what is going wrong from the information taken
from the development log below. WHen i start WEBrick and try and view
a page on the localhost i get the following error, “We’re sorry, but
something went wrong.We’ve been notified about this issue and we’ll
take a look at it shortly.”
I’m a complete beginner and really want to start learning Ruby on
rails, but cannot at the moment get past the setup phase despite a
long time trying and i feel I’m almost there. Hope someone can help.

Logfile created on Wed Mar 24 17:13:17 +0000 2010/!\ FAILSAFE /!\

Wed Mar 24 17:13:27 +0000 2010
Status: 500 Internal Server Error
uninitialized constant Encoding
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/
active_support/dependencies.rb:443:in load_missing_constant' /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/ active_support/dependencies.rb:80:inconst_missing’
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/
active_support/dependencies.rb:92:in const_missing' /usr/local/lib/ruby/gems/1.8/gems/sqlite3-0.0.8/lib/sqlite3/ encoding.rb:9:infind’
/usr/local/lib/ruby/gems/1.8/gems/sqlite3-0.0.8/lib/sqlite3/
database.rb:66:in initialize' /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/ active_record/connection_adapters/sqlite3_adapter.rb:13:innew’
/usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/
active_record/connection_adapters/sqlite3_adapter.rb:13:in
sqlite3_connection' /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/ active_record/connection_adapters/abstract/connection_pool.rb:223:insend’
/usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/
active_record/connection_adapters/abstract/connection_pool.rb:223:in
new_connection' /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/ active_record/connection_adapters/abstract/connection_pool.rb:245:incheckout_new_connection’
/usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/
active_record/connection_adapters/abstract/connection_pool.rb:188:in
checkout' /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/ active_record/connection_adapters/abstract/connection_pool.rb:184:inloop’
/usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/
active_record/connection_adapters/abstract/connection_pool.rb:184:in
checkout' /usr/local/lib/ruby/1.8/monitor.rb:242:insynchronize’
/usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/
active_record/connection_adapters/abstract/connection_pool.rb:183:in
checkout' /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/ active_record/connection_adapters/abstract/connection_pool.rb:98:inconnection’
/usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/
active_record/connection_adapters/abstract/connection_pool.rb:326:in
retrieve_connection' /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/ active_record/connection_adapters/abstract/connection_specification.rb: 123:inretrieve_connection’
/usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/
active_record/connection_adapters/abstract/connection_specification.rb:
115:in connection' /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/ active_record/query_cache.rb:9:incache’
/usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/
active_record/query_cache.rb:28:in call' /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/ active_record/connection_adapters/abstract/connection_pool.rb:361:incall’
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/
action_controller/string_coercion.rb:25:in call' /Users/peterorpete/.gem/ruby/1.8/gems/rack-1.0.1/lib/rack/head.rb: 9:incall’
/Users/peterorpete/.gem/ruby/1.8/gems/rack-1.0.1/lib/rack/
methodoverride.rb:24:in call' /usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/ action_controller/params_parser.rb:15:incall’
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/
action_controller/session/cookie_store.rb:93:in call' /usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/ action_controller/failsafe.rb:26:incall’
/Users/peterorpete/.gem/ruby/1.8/gems/rack-1.0.1/lib/rack/lock.rb:
11:in call' /Users/peterorpete/.gem/ruby/1.8/gems/rack-1.0.1/lib/rack/lock.rb: 11:insynchronize’
/Users/peterorpete/.gem/ruby/1.8/gems/rack-1.0.1/lib/rack/lock.rb:
11:in call' /usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/ action_controller/dispatcher.rb:114:incall’
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/
action_controller/reloader.rb:34:in run' /usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/ action_controller/dispatcher.rb:108:incall’
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/rails/rack/
static.rb:31:in call' /Users/peterorpete/.gem/ruby/1.8/gems/rack-1.0.1/lib/rack/ urlmap.rb:46:incall’
/Users/peterorpete/.gem/ruby/1.8/gems/rack-1.0.1/lib/rack/
urlmap.rb:40:in each' /Users/peterorpete/.gem/ruby/1.8/gems/rack-1.0.1/lib/rack/ urlmap.rb:40:incall’
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/rails/rack/
log_tailer.rb:17:in call' /Users/peterorpete/.gem/ruby/1.8/gems/rack-1.0.1/lib/rack/ content_length.rb:13:incall’
/Users/peterorpete/.gem/ruby/1.8/gems/rack-1.0.1/lib/rack/handler/
webrick.rb:50:in service' /usr/local/lib/ruby/1.8/webrick/httpserver.rb:104:inservice’
/usr/local/lib/ruby/1.8/webrick/httpserver.rb:65:in run' /usr/local/lib/ruby/1.8/webrick/server.rb:173:instart_thread’
/usr/local/lib/ruby/1.8/webrick/server.rb:162:in start' /usr/local/lib/ruby/1.8/webrick/server.rb:162:instart_thread’
/usr/local/lib/ruby/1.8/webrick/server.rb:95:in start' /usr/local/lib/ruby/1.8/webrick/server.rb:92:ineach’
/usr/local/lib/ruby/1.8/webrick/server.rb:92:in start' /usr/local/lib/ruby/1.8/webrick/server.rb:23:instart’
/usr/local/lib/ruby/1.8/webrick/server.rb:82:in start' /Users/peterorpete/.gem/ruby/1.8/gems/rack-1.0.1/lib/rack/handler/ webrick.rb:14:inrun’
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/commands/
server.rb:111
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
gem_original_require' /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:inrequire’
script/server:3

dont worry about this, i just stopped trying to have a version of ruby
in my local folder and everything seems to work fine now

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs