Trouble starting mongrel


#1

i am having a weird problem starting mongrel on a current live server…

when i start it as script/console, i get[1]…

when i start it from the command line, i am getting[2]…

it runs fine on my development system…

i am not even sure where to look to hunt this one down…

anyone have any ideas?

thanks!


[1]

Loading production environment (Rails 2.2.2)
/usr/lib64/ruby/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:530:in
send':NoMethodError: undefined methodcache_template_loading=’ for
ActionView::Base:Class
/usr/lib64/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:442:in
`load_missing_constant’:NameError: uninitialized constant
Localization::CONFIG


[2]

/usr/lib64/ruby/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:530:in
send': undefined methodcache_template_loading=’ for
ActionView::Base:Class (NoMethodError)
from
/usr/lib64/ruby/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:530:in
initialize_framework_settings' from /usr/lib64/ruby/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:529:ineach’
from
/usr/lib64/ruby/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:529:in
initialize_framework_settings' from /usr/lib64/ruby/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:526:ineach’
from
/usr/lib64/ruby/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:526:in
initialize_framework_settings' from /usr/lib64/ruby/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:154:inprocess’
from
/usr/lib64/ruby/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:112:in
send' from /usr/lib64/ruby/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:112:inrun’
… 12 levels…
from
/usr/lib64/ruby/gems/1.8/gems/mongrel-1.1.5/bin/…/lib/mongrel/command.rb:212:in
run' from /usr/lib64/ruby/gems/1.8/gems/mongrel-1.1.5/bin/mongrel_rails:281 from /usr/bin/mongrel_rails:19:inload’
from /usr/bin/mongrel_rails:19


#2

On Mar 25, 2:34 pm, Sergio R. removed_email_address@domain.invalid
wrote:

Loading production environment (Rails 2.2.2)
/usr/lib64/ruby/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:530:in
send':NoMethodError: undefined methodcache_template_loading=’ for

cache_template_loading is a setting that was removed from rails (i
forget exactly in which version). Remove it from your config file and
rails should start. The fact that it works in development probably
means you’re running a different rails version there.

Fred


#3

rails should start. The fact that it works in development probably
means you’re running a different rails version there.

thanks, fred… removing now…

the weird part is that i am running 2.2.2 on both machines…

hmm…

thanks again!