Trouble setting up debugger (ruby-debug in Rails 2.0)


#1

So I’m a newbie, trying to get better with the testing and debugging.
Upgraded to Rails 2.0 and decided to use the ruby-debug gem. Installed
gem successfully…

gem install ruby-debug
Successfully installed ruby-debug-0.10.0
1 gem installed
Installing ri documentation for ruby-debug-0.10.0…
Installing RDoc documentation for ruby-debug-0.10.0…

but when I run my app with the -u (–debugger) switch get the following
message:

script\server -u
=> Booting Mongrel (use ‘script/server webrick’ to force WEBrick)
=> Rails application starting on http://0.0.0.0:3000
You need to install ruby-debug to run the server in debugging mode.
With gems, use ‘gem install ruby-debug’

but as you can see, it is already installed?! Get same message when
trying to use WEBrick as well as Mongrel.

I am running Rails 2.0.2 and Ruby 1.8.6 on Windows XP (sorry). Tried
messing with a few versions of rubygems to fix this (0.9.4 and 0.9.5)
and am currently using 1.0.1.

Any help?

Thanks!

Martyn.


#2

Hi Martyn,

The problem is that the error message is not clear. Here is a suggestion
to modify base.rb to get a clearer message:

http://dev.rubyonrails.org/ticket/10593

In my case, the problem was made immediately clear with the above fix,
showing:

#<Gem::LoadError: RubyGem version error: ruby-debug-base(0.9.3 not =
0.10.0)>

I had version issues. ruby-debug was version 0.10.0 and ruby-debug-base
was 0.9.3. Because I couldn’t upgrade ruby-debug-base to 0.10.0, I
downgraded ruby-debug to 0.9.3 with the following commands:

gem install ruby-debug -v 0.9.3
gem uninstall ruby-debug -v 0.10.0

and problem went away!

Hope this helps,

Andres Montano
http://www.gaugeus.com/ramblings

#3

I not sure if this helps, but I was unable to gem install ruby-debug
(0.10.0) on windows because it was trying to build a native extension. I
posted the resolution at my blog at
http://amitava1.blogspot.com/2008/02/gem-install-ruby-debug-fails-in-windows.html.

Amitava

Martyn Hill wrote:

So I’m a newbie, trying to get better with the testing and debugging.
Upgraded to Rails 2.0 and decided to use the ruby-debug gem. Installed
gem successfully…

gem install ruby-debug
Successfully installed ruby-debug-0.10.0
1 gem installed
Installing ri documentation for ruby-debug-0.10.0…
Installing RDoc documentation for ruby-debug-0.10.0…

but when I run my app with the -u (–debugger) switch get the following
message:

script\server -u
=> Booting Mongrel (use ‘script/server webrick’ to force WEBrick)
=> Rails application starting on http://0.0.0.0:3000
You need to install ruby-debug to run the server in debugging mode.
With gems, use ‘gem install ruby-debug’

but as you can see, it is already installed?! Get same message when
trying to use WEBrick as well as Mongrel.

I am running Rails 2.0.2 and Ruby 1.8.6 on Windows XP (sorry). Tried
messing with a few versions of rubygems to fix this (0.9.4 and 0.9.5)
and am currently using 1.0.1.

Any help?

Thanks!

Martyn.