Trouble Running my app

Im having trouble running my app :frowning:

I get the error message application error rails failed to start
properly.

So not being a total idiot(I may regret saying that) i checked the
logs and there was a problem in the server log only. It stated
premature end to headers for dispatch.cgi

I then tried to run the dispatch.cgi from a terminal expecting to see
error 500 but instead i get this:

[email protected] public]# ./dispatch.cgi
Status: 400 Bad Request
/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/
dependencies.rb:405:in to_constant_name': Anonymous modules have no name to be referenced by (ArgumentError) from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/ active_support/dependencies.rb:215:inqualified_name_for’
from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/
active_support/dependencies.rb:477:in const_missing' from /usr/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/dispatcher.rb:117:inreset_after_dispatch’
from /usr/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/dispatcher.rb:51:in
`dispatch’
from ./dispatch.cgi:10

Which means nothing to me and google isn’t bringing anything up :frowning:

I have tried to reinstall rails and also updated gems and again no
luck:(

Any clues at all would be most helpful

Cheers in advance

Matt

Has nobody any ideas how I should go about solving this?

Its really annoying me now:(

Please im going insane. if there is anymore information that is
required please dont hesitate to ask I will provide it. I just cant
see the problem and my efforts with google have been exhausted.

Matt

Hi Matt,

Try the rails-deploy list with this question. It looks more like an
infrastructure question. Can you start any Rails app? If you haven’t
tried
it, just create a small table, then scaffold a model / controller on it
and
work up from there.

Sorry I can’t be more help.

Bill

Cheers Bill didn’t know such a place existed thanks.

Incidently I can get the scaffold working etc, and also can run the
webrick server too.

Just can’t run the main apache way.

Thanks again

On 21-Feb-07, at 10:12 AM, Matt wrote:

On 21 Feb, 15:00, “Bill W.” [email protected] wrote:

Bill

as Bill said, try simple things first Matt.

build a new project, and serve that from apache.

If that doesn’t work, and it serves from webrick, then you’ve got an
apache config problem - which might include file permissions, etc.

If it does, then you’re likely dealing with an old (pre 1.2) project?
did you run “rake rails:update” - does your environment.rb set a
specific rails version to run?

narrowing down your scope of concerns, will help you post info that
can help us help you. The deploy list has a bunch of crazy-deploy-fu
people (who are likely here as well), but the signal-to-noise ratio
is higher there.

Jodi

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs