Trouble installing Visual Ruby


#1

Hello,

I am behind a proxy, but using the SET HTTP_PROXY command seems to work.
System in Win 7 64 bit, I installed 32 bit ruby 1.9.3 as recommended.

So I was able to use
gem install visualruby

but when I try
vr

I get this error:

E:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
require': cannot load such file -- cairo.so (LoadError) from E:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:i nrequire’
from
E:/Ruby193/lib/ruby/gems/1.9.1/gems/cairo-1.12.9-x86-mingw32/lib/ca
iro.rb:46:in rescue in <top (required)>' from E:/Ruby193/lib/ruby/gems/1.9.1/gems/cairo-1.12.9-x86-mingw32/lib/ca iro.rb:42:in<top (required)>’
from
E:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:i
n require' from E:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:i nrequire’
from
E:/Ruby193/lib/ruby/gems/1.9.1/gems/glib2-2.2.2-x86-mingw32/lib/gli
b2.rb:97:in <top (required)>' from E:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:i nrequire’
from
E:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:i
n require' from E:/Ruby193/lib/ruby/gems/1.9.1/gems/gtk2-2.2.2-x86-mingw32/lib/gtk2 /base.rb:12:in<top (required)>’
from
E:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:i
n require' from E:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:i nrequire’
from
E:/Ruby193/lib/ruby/gems/1.9.1/gems/gtk2-2.2.2-x86-mingw32/lib/gtk2
.rb:11:in <top (required)>' from E:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:i nrequire’
from
E:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:i
n require' from E:/Ruby193/lib/ruby/gems/1.9.1/gems/gtksourceview2-2.2.2-x86-mingw3 2/lib/gtksourceview2.rb:8:in<top (required)>’
from
E:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:i
n require' from E:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:i nrequire’
from
E:/Ruby193/lib/ruby/gems/1.9.1/gems/visualruby-1.0.16/vr:4:in <top (required)>' from E:/Ruby193/bin/vr:23:inload’
from E:/Ruby193/bin/vr:23:in `’


Thank you for any help!

Bye
Richard