Trouble installing Ruby on Rails with Apache 2 on Linux

Hi, I’m running Fedora Core 5 Linux on an x86 machine with Apache 2.2.
I’m trying to install Ruby on Rails using the instructions here
( If anyone has
better instructions, please let me know!

I was unable to install mod_fastcgi because of errors it was giving me.
Skipping that step, I completed the rest of the steps, including

echo “FastCgiIpcDir /tmp/fcgi/” >>
echo “AddHandler fastcgi-script .fcgi” >>
echo “FastCgiWrapper On” >> /usr/local/apache2/conf/httpd.conf

but got this error when I restarted my Apache 2 server …

Syntax error on line 448 of /usr/local/apache2/conf/httpd.conf:
Invalid command ‘FastCgiIpcDir’, perhaps misspelled or defined by a
module not included in the server configuration

Any ideas what’s going wrong?

Thanks, - Dave

Hi Dave,

the error is probably because you couldn’t install mod_fastcgi. If you
want to go with Apache2, there are a few other options besides fastcgi
to get Ruby on
Rails going. Apache2 + fcgid or Apache2 + Mongrel. The last option is
the most popular at the moment. I have a couple of links up at

that point to some good tutorials that should get you up and running
very quickly.

Kind regards,

Nick S.

Thanks. These are some good links, but what I can’t seem to find is
what directives I need to put in my httpd.conf file to recognize pages
written in ruby and pass those along to the correct interpreter. Do
you have a tutorial with the step-by-step setup?

Thanks, -Dave

So long as your document root is pointed at /public and .htaccess is
turned on you should be OK (unless you are configuring for something
fancy like Mongrel).

On Jan 24, 9:50 am, “[email protected]