Trouble installing ruby-debug

I have installed ruby-debug several times without any problems, but am
running into one when rebuilding my system.

I am typing in the following command to install it as root:

gem install ruby-debug -y

I keep getting the following response:

INFO: gem install -y is now default and will be removed
INFO: use --ignore-dependencies to install only the gems you list
ERROR: While executing gem … (Gem::RemoteFetcher::FetchError)
Gem::RemoteFetcher::FetchError: bad response Not Found 404 reading
http://gems.rubyforge.org/gems/linecache-0.4.gem

Now went to the URL indicated above and sure enough the
linecache-0.4.gem does not exist. linecache-0.1.gem through
linecache-0.3.gem exist however. Is this a problem in the gem
installer?

gem --version indicates a gem version of 1.1.0.

Any ideas anyone?

Thanks.

Bharat

try installing the sources gem first, and the rubyforge one… it
might help

On Apr 10, 4:17 pm, Bharat R. [email protected]

I am sorry but I don’t understand what do you mean when you say “try
installing the sources gem first, and the rubyforge one… it might
help” - How do I do that?
Bharat

Follow up questions:

  1. I found that the gem install ruby-debug -y command had installed:
    ruby-debug-0.10.1 and ruby-debug-base-0.10.1. I thought that the most
    recent version of ruby-debug was 0.9.3? Why did it install 0.10.1 then?

  2. I am trying to install ruby-debug-ide which gives me the following
    response:

ERROR: Error installing ruby-debug-ide:
ruby-debug-ide requires ruby-debug-base (= 0.10.0)

Please advise.

Bharat

Apoligies for not thinking through and investigating. Based on your
suggestion, here is what I did.

gem install sources

then

gem install ruby-debug -y

And everything worked fine. A bit of educational question however, what
exactly is the function of sources gem?

Thanks again.

Bharat

http://membres.lycos.fr/ccpfordz

Thanks Tim. Works.

Bharat R.:

ruby-debug-0.10.1 appears to be a broken release.

I posted some instructions at the top of here on how to roll back to
0.10.0:

http://code.leadmediapartners.com/tools/rubyamp

(i’ll remove the instructions when the problem is resolved, for those
of you who stumble upon this message after the fact)

Tim

On Apr 10, 8:42 am, Bharat R. [email protected]

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs