Trouble installing Rails 1.2.6


#1

Hello!

I’m a user of a Ubuntu box I have just installed ruby, rails and other
gems
and i was willing to try mephistoblog, which uses rails version 1.2.6.

The problem is that when I try to install that version it says the
following:

dereck@yoshi:~$ gem install rails -v 1.2.6
ERROR: could not find rails locally or in a repository
dereck@yoshi:~$

I have tried with the same PC, the same conection but in Windows and it
worked perfectly.

I’m using ruby gems version 1.1.0.

Any guess or idea of what might be the problem?


#2

Thank you very much, in advance :smiley:


#3

Hey Just go for gem uninstall rails then go for gem install rails -v
1.2.6.I solved on my Ubuntu box previously.

  • Rajesh

On Sun, Apr 6, 2008 at 11:57 PM, Alejandro R. removed_email_address@domain.invalid
wrote:

Thank you very much, in advance :smiley:


Happiness keeps u Sweet, Trials keep u Strong, Sorrow keeps u Human,

Failure Keeps u Humble, Success keeps u Glowing, But only God Keeps u

Going…

Keep Going…


#4

Hey Just go for gem uninstall rails then go for gem install rails -v
1.2.6. I solved on my Ubuntu box previously.

thx for the advice but I’m still getting the same error : (

it’s curious because I can do “gem install rails” to install version
2.0.2
and it works perfectly :-S


#5

Hello, how about following google group’s discussion?

Ruby on Rails: Talk - Remote install of 1.2.6
http://groups.google.ca/group/rubyonrails-talk/browse_thread/thread/355af967bc3eb639/2c7ae237bbcb052a

I got same error.
I download
activesupport-1.4.4.gem,
activerecord-1.15.6.gem,
actionpack-1.13.6.gem,
actionmailer-1.3.6.gem,
rails-1.2.6.gem from rubyforge,
and install them by gem command manually, then,
I could install rails-1.2.6 !! :slight_smile:

("–include-dependencies" option didn’t work correctly in my
environment, so I had to download get each gem files.)


#6

As Shawn P. wrote me:

sudo gem install --source http://gems.rubyforge.org rails -v 1.2.6 -y

It appears that they are no longer hosting old gems at
gems.rubyonrails.org.

it worked for me.
gl ; )